Closed Bug 414737 Opened 14 years ago Closed 14 years ago

Unable to launch Download manager at all if browser.download.manager.closeWhenDone = true

Categories

(Toolkit :: Downloads API, defect)

x86
Windows XP
defect
Not set
major

Tracking

()

VERIFIED DUPLICATE of bug 414214

People

(Reporter: mishail.mishail, Unassigned)

Details

Attachments

(4 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008012804 Minefield/3.0b3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008012804 Minefield/3.0b3pre

When browser.download.manager.closeWhenDone = true ("Close the Download Manager when all downloads are complete" checkmark is checked, and even if it's disabled due to "Show Download Manager window when a download begins" is disabled)

Reproducible: Always

Steps to Reproduce:
1. Set the "Show Download Manager window when a download begins" checkmark
2. Set the "Close the Download Manager when all downloads are complete" checkmark
3. Try to launch Download Manager (tools->Downloads or Ctrl+J)

Actual Results:  
Download Manager appears for a moment and then it's closed

Expected Results:  
Download Manager is shown

That didn't happen on trunk build from Jan-08-2008

Even if you clear "Show Download Manager window when a download begins" checkmark (and in this case "Close the Download Manager when all downloads are complete" will be disabled (grayed-out)) the problem still will be there.

It happens every time if browser.download.manager.closeWhenDone = true
Opps... It's seems to be dup of Bug 414214 
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 414214
Verified dup
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.