'Bookmark This Link' does not display dialog

RESOLVED FIXED in Firefox 3 beta3

Status

()

RESOLVED FIXED
11 years ago
8 years ago

People

(Reporter: matt.babbs, Assigned: mano)

Tracking

Trunk
Firefox 3 beta3
Points:
---
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008013003 Minefield/3.0b3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008013003 Minefield/3.0b3pre

When selecting 'Bookmark This Link' from the context menu, no dialog appears. Instead, the bookmark is just put on the end of the Bookmarks Menu.

Reproducible: Always

Steps to Reproduce:
1. Load any page
2. Bring up the context menu for a link
3. Click 'Bookmark This Link'
Actual Results:  
No dialog is displayed to indicate that the bookmark was added or to allow editing. The bookmark appears at the end of the Bookmarks Menu.

Expected Results:  
'Page Bookmarked' dialog should be shown.
Status: UNCONFIRMED → NEW
Component: Bookmarks → Places
Ever confirmed: true
Flags: blocking-firefox3?
OS: Windows XP → All
QA Contact: bookmarks → places
Hardware: PC → All
Version: unspecified → Trunk

Comment 1

11 years ago
Confirmed.  Everything should be consistent.

Comment 2

11 years ago
If nothing else at least put the new bookmark in the unfiled bookmarks folder like clicking on the star does.  
(Reporter)

Comment 3

11 years ago
I think the minimum correct behavior would be to show the new 'Page Bookmarked' dialog. Ideally, it should show a similar dialog, but labeled 'Link Bookmarked', and displayed centered rather than under the star.

Regression range:
Working correctly in 20080129-1924

No dialog & bookmark created in 20080129-2038
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1201663440&maxdate=1201667879

and 20080129-2215
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1201667880&maxdate=1201673699

No dialog; bookmark on end of Bookmarks Menu in 20080129-2251
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1201673700&maxdate=1201675859

Comment 4

11 years ago
I'm not understanding your regression range.  Can you post,
Works In: 
Broken In:

Thanks
(Reporter)

Comment 5

11 years ago
Ah, OK, sorry. Thing is, it was showing two broken behaviors.

Works In: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre)
Gecko/200801291924 Minefield/3.0b3pre ID:200801291924

Broken In: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre)
Gecko/200801292251 Minefield/3.0b3pre ID:200801292251

But the in-between builds, 200801292038 and 200801292215, don't add a bookmark
at all for 'Bookmark This Link'. Perhaps due to Bug 414776?

Updated

11 years ago
Duplicate of this bug: 414878

Comment 7

11 years ago
Yeah bookmarking was completely broken in those 2038 and 2215 builds so, we can't for certain say which bug caused this bug I'd put my money on bug 393509.

------

From the dupe bug (bug 414878)
(In reply to comment #1)
> Needs to change the following line of PlacesCommandHook.bookmarkLink.
> - this.showEditBookmarkPopup
> + StarUI.showEditBookmarkPopup
> 
Blocks: 393509
Fixed in bug 412027.
Assignee: nobody → mano
Target Milestone: --- → Firefox 3 beta3
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Flags: blocking-firefox3? → blocking-firefox3+

Comment 9

11 years ago
VERIFIED

Updated

11 years ago
Status: RESOLVED → VERIFIED

Comment 10

10 years ago
Not fixed on Linux.
running:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090313 Minefield/3.2a1pre

The bookmark this page panel is never displayed, the error in the console says:

Error: elt is null
Source File: chrome://browser/content/browser.js
Line: 5834

Strange, as this is fixed in 3.1b3.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 11

10 years ago
Never mind. after a full rebuild of my checkout, this is fixed. My checkout was borked (again).
Status: REOPENED → RESOLVED
Last Resolved: 11 years ago10 years ago
Resolution: --- → FIXED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.