Two locationbars (one in navigation bar, one in menu bar)

VERIFIED FIXED in Firefox 3 beta3

Status

()

P1
normal
VERIFIED FIXED
11 years ago
11 years ago

People

(Reporter: aryx, Assigned: dao)

Tracking

({regression})

Trunk
Firefox 3 beta3
regression
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Created attachment 300384 [details]
two locationbars, one c... searchbar

Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9b3pre) Gecko/2008013004 Minefield/3.0b3pre - Build ID: 2008013004

Once upon a time, I had customized Firefox and moved the locationbar from the navigation bar to the menu bar. After the nightly update, there are two locationbars. Only the navigation-location-bar works, pressing enter in the other will reload the page independent of the locationbar content.
Flags: blocking-firefox3?
I got something similar. I had my bookmarks on the menu bar with the bookmarks toolbar empty (and unticked so it wasn't shown). After the nightly update I had a set of bookmarks still on my menu bar, but my bookmarks toolbar had returned with another set of bookmarks on too.

After some faffing about with the customization things are back to normal, but it was a strange experience.

Comment 2

11 years ago
Is this due to userChrome.css hacks?
No, I don't perform any (relevant) userChrome.css stuff.
Me neither. A follow-up patch in bug 404109 may solve this issue.
(Assignee)

Comment 5

11 years ago
Created attachment 300406 [details] [diff] [review]
don't create duplicate items
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #300406 - Flags: review?(gavin.sharp)
(Assignee)

Updated

11 years ago
Blocks: 404109
(Assignee)

Updated

11 years ago
Status: ASSIGNED → NEW
Component: Location Bar and Autocomplete → Toolbars
OS: Windows XP → All
Hardware: PC → All
(Assignee)

Updated

11 years ago
Assignee: dao → nobody
Priority: -- → P1
QA Contact: location.bar → toolbars
Target Milestone: --- → Firefox 3 beta3
(Assignee)

Updated

11 years ago
Assignee: nobody → dao
Attachment #300406 - Flags: review?(gavin.sharp)
Attachment #300406 - Flags: review+
Attachment #300406 - Flags: approval1.9b3?
Flags: blocking-firefox3? → blocking-firefox3+
Comment on attachment 300406 [details] [diff] [review]
don't create duplicate items

a=beltzner for beta3
Attachment #300406 - Flags: approval1.9b3? → approval1.9b3+
mozilla/toolkit/content/widgets/toolbar.xml 	1.45 

(Filed bug 414951 to fix the commit message!)
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 8

11 years ago
Verified fix on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3)
Gecko/2008020514 Firefox/3.0b3
Status: RESOLVED → VERIFIED
(Assignee)

Updated

11 years ago
Depends on: 423770
You need to log in before you can comment on or make changes to this bug.