Middle-click on a tag makes an assertion failure

RESOLVED DUPLICATE of bug 400109

Status

()

RESOLVED DUPLICATE of bug 400109
11 years ago
9 years ago

People

(Reporter: zwnj, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Middle-click on a tag  in Places folder of Bookmarks Toolbar makes an assertion failure:

ASSERT: Node QI Failed
Stack Trace: 
0:QI_node([xpconnect wrapped (nsISupports, nsINavHistoryResultNode, nsINavHistoryContainerResultNode)],nsINavHistoryQueryResultNode)
1:asQuery([xpconnect wrapped (nsISupports, nsINavHistoryResultNode, nsINavHistoryContainerResultNode)])
2:PU_getURLsForContainerNode([xpconnect wrapped (nsISupports, nsINavHistoryResultNode, nsINavHistoryContainerResultNode)])
3:PU_openContainerInTabs([xpconnect wrapped (nsISupports, nsINavHistoryResultNode, nsINavHistoryContainerResultNode)],[object MouseEvent])
4:PC_openLinksInTabs([object MouseEvent])
5:BT_onClick([object MouseEvent])
6:onclick([object MouseEvent])
Dupe of Bug 400109 ?
(Reporter)

Comment 2

11 years ago
Bug 400109 Comment 10 has the same report, but I'm not sure a fix for that fixes this one too.  Anyone?  If not, blocking?
WFM

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008022714 Minefield/3.0b4pre
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
well actually better marking this as a dupe
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 400109
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.