Visual Studio Just-In-Time Debugger error. Unhandled Win32 exception in firefox.exe

VERIFIED INCOMPLETE

Status

()

Firefox
General
VERIFIED INCOMPLETE
11 years ago
8 years ago

People

(Reporter: bugzilla1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2

Here's the error message I get:
Visual Studio Just-In-Time Debugger error
An unhandled Win32 exception in occurred in firefox.exe [2692]. Just-In-Time debugging this exception failed with the following error: No installed debugger has Just-In-Time debugging enabled. In Visual Studio, Just-In-Time debugging can be enabled from Tools/Options/Debugging/Just-In-Time.
Chech the documentation index for 'Just-In-Time, errors' for more information.

Firefox does not close until I click OK.  This crash does NOT open a Windows Error Reporting message.

I'm not sure what causes the error.  I always get it after opening a new tab, while the page is loading. It has happened about three times, but it is not predictable.  It does not seem to be caused by any particular websites.  It might be related to Flash, but it hasn't happened enough to know for sure.  Flash works normally most of the time.

I don't have Visual Studio installed anymore (I did previously, but I uninstalled it a while before I started using Firefox 3 beta).

Reproducible: Couldn't Reproduce

Steps to Reproduce:
1.
2.
3.



About 50 open tabs
Extensions:
Adblock Plus
DOM inspector
Download Helper
NoScript
(Reporter)

Comment 1

11 years ago
Created attachment 300528 [details]
Error Message
(Reporter)

Comment 3

11 years ago
But will disabling JIT keep Firefox from crashing?
The just in time debugger stuff is just a red herring. Firefox is crashing due to an unhandled exception and windows is trying to start the debugger to let you try to debug the crash. You need to remove the definition of the Visual Studio debugger in your registry.

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug]
"Auto"="1"
"UserDebuggerHotKey"=dword:00000000
"Debugger"="..."

The easiest thing to do is change the "Debugger"="..." to "xDebugger"="...." in case you ever want to reactivate it.

As it stands, this bug is not very useful since there is nothing that would allow anyone else to reproduce the bug. Can you try to determine exactly what steps are required to reproduce this crash? Once you disable the debugger entry, see if you get a talkback report for the crash and report it back here.

->incomplete until we know more. please reopen if you can give us steps to reproduce the bug. thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INCOMPLETE

Updated

8 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.