Closed Bug 415064 Opened 14 years ago Closed 14 years ago

child elements scrollbars does not disappear when parent is made hidden (OSX only)

Categories

(Firefox :: General, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 187435

People

(Reporter: jl, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; sv-SE; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; sv-SE; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

When a parent element contains a child with scrollbars and the parent is made hidden the child is also hidden. On Mac OS X however the scrollbars from the child remain visible.

Reproducible: Always

Steps to Reproduce:
The following code snippet causes the a scrollbar to appear, that should have been hidden.
    <div style="background-color: yellow; width: 100px; height:100px; visibility:hidden; ">
        <div style="background-color: blue; width:50px; height:50px; overflow:scroll;"/>    
    </div>
Actual Results:  
Rouge scrollbars appear throughout web page.

Expected Results:  
The scrollbars of child elements should be hidden along with the rest of the element when parent elements are made hidden.

This is a problem on Mac OS X only.
This has already been fixed and will be available in Firefox 3
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 187435
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.