Double clicking items in Bookmark panel fails after hiding sidebar

VERIFIED FIXED in M18

Status

SeaMonkey
Bookmarks & History
P2
major
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Marc Loiselle, Assigned: Radha on family leave (not reading bugmail))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-][dogfood-][rjc][nsbeta3+])

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.14-5.0 i586; en-US; m16) Gecko/20000602
BuildID:    2000060208

Bookmark items won't load from Bookmark panel after toggling view of sidebar.

Reproducible: Always
Steps to Reproduce:
1.Start mozilla (with sidebar set to visible on load)
2.Toggle the sidebar using View->Sidebar
3.Try to open a bookmark from the Bookmarks panel.

Expected Results:  Should load bookmark.

"BrowserAppCore is not initialised" message in console.

Comment 1

18 years ago
Im on 2000060409 on Linux right now and I'm getting this same error.  Moving to
new.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

18 years ago
seeing win98 as well. Marking OS all.

Putting nsbeta2 and regression keywords to attract attention, this is pretty
"important" for beta2. upping severity as well.
Severity: normal → major
Keywords: nsbeta2, regression
OS: Linux → All

Comment 3

18 years ago
OK, someone deleted his profile, and this fixed it. Can you confirm that this
worked?
Killing keywords.
Keywords: nsbeta2, regression

Comment 4

18 years ago
OK, seems that my previous comment was kidna wrong, it fixes it, but reoccurs
when you follow the steps of the reporter.

Going to make this dogfood, I think this should be in nsbeta2.
Keywords: dogfood

Comment 5

18 years ago
Putting on [nsbeta2+][dogfood-] radar.  Not critical to fix ASAP since there is 
a workaround, but definitely fix for beta2.
Whiteboard: [nsbeta2+][dogfood-]

Comment 6

18 years ago
Added "rjc" to status whiteboard since we need Robert's help with this while
slamm is on sabbatical.
Priority: P3 → P2
Whiteboard: [nsbeta2+][dogfood-] → [nsbeta2+][dogfood-][rjc]
Target Milestone: --- → M18

Comment 7

18 years ago
actually appears to be a dup of 41240, but will mark that a dup of this since 
this has garnered more attention (and nsbeta2+)

Comment 8

18 years ago
*** Bug 41240 has been marked as a duplicate of this bug. ***

Comment 9

18 years ago
*** Bug 42176 has been marked as a duplicate of this bug. ***
We need someone to accept this bug so we can get a eta (if possible)
Reassigning to radha as her last change to bm-panel.js is the hot-spot... her
CVS comment:

> Call appCore.loadURL(url) instead of doing window.content.location.href=url

Radha, it looks like window.content.appCore isn't always available, when it
should be.
Assignee: slamm → radha
Status: NEW → ASSIGNED

Comment 12

18 years ago
correcting component : bookmarks.
Component: Sidebar → Bookmarks
QA Contact: shrir → claudius
(Reporter)

Comment 13

18 years ago
Same thing happens when switching skins.

Comment 14

18 years ago
Making this "nsbeta2-" since I don't think it's a must-have for beta 2.

Radha, should Ben get this bug?
Whiteboard: [nsbeta2+][dogfood-][rjc] → [nsbeta2-][dogfood-][rjc]

Comment 15

18 years ago
nsbeta3
Keywords: nsbeta3

Comment 16

18 years ago
Nav triage team: [nsbeta3+]
Whiteboard: [nsbeta2-][dogfood-][rjc] → [nsbeta2-][dogfood-][rjc][nsbeta3+]
This got fixed with rjc's latest checkin to bm-panel.js
really marking fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
Adding keyword to bugs which already show a nsbeta2 triage value in the status 
whiteboard so the queries don't get screwed up.
Keywords: nsbeta2

Comment 20

18 years ago
VERIFIED Fixed with 2000082108 builds
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.