Closed Bug 415100 Opened 12 years ago Closed 11 years ago

vista x64 msys compat

Categories

(mozilla.org :: MozillaBuild, task)

x86
Windows Vista
task
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ted, Unassigned)

References

()

Details

The URL says that a newer release of MSYS has fixed some Vista x64 compat issues, and his workaround is to download the msys dll and replace the one in MozillaBuild.  We should just update our copy for the next release.
luser: I confirm the 1.0.11 MSYS files do fix the bash forking problem on Vista 64-bit.
Hm, looks like MozillaBuild 1.3 release fixed this... luser, can you verify?
I didn't update any MSYS stuff in 1.3. I did embed manifests in all the exes though, maybe that helped something?
No, I'm afraid it didn't.
installed MozillaBuild 1.3 and bash crashes

Vista x64 SP1
It's still broken on x64.
See http://wp.asztal.net/2008/09/mozillabuild-13-on-64-bit-vista/ . The binaries linked from there get around the bash fork problem. The Mozillabuild binaries should be updated. OTOH, the listed workaround for the the \Microsoft problem did not work for me. And I'm using VC9 Professional.
Clearly it is broken or this bug would be fixed. "Me too" comments are not helpful.
Duplicate of this bug: 427724
I haven't tried building, but with this + the fix from bug 402226, bash starts up just fine on my x64 vm:
http://hg.mozilla.org/mozilla-build/rev/fdf0cb1d1f18
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Is there a new mozillabuild package to test ? I don't use the mozillabuild batch files at all. I have my own. Working bash binaries on the other hand are required.
(In reply to comment #11)
> I have a test pre-release build here:
> http://people.mozilla.com/~tmielczarek/MozillaBuildSetup-1.4pre.exe

I installed this to Vista x64 and I cloned mozilla-central to /s/mozilla-f/src and I tried to build a debug build but it failed.

> creating js-config.h
> invoking make to create js-config script
> make.exe[2]: Entering directory `/s/mozilla-f/firefox-debug-build/js/src'
> make.exe[2]: Leaving directory `/s/mozilla-f/firefox-debug-build/js/src'
> make.exe[2]: Entering directory `/s/mozilla-f/firefox-debug-build/js/src'
> make.exe[2]: /s/mozilla-f/firefox-debug-build/js/src/I:/sys/mozilla-build/msys/b
> in/make.exe: Command not found
> configure: error: /s/mozilla-f/src/js/src/configure failed for js/src
> *** Fix above errors and then restart with               "make -f client.mk buil
> d"
> make[1]: *** [configure] Error 1
> make[1]: Leaving directory `/s/mozilla-f/src'
> make: *** [/s/mozilla-f/src/../firefox-debug-build/Makefile] Error 2

I'm not sure this is a problem of the pre build.
Yeah, I hit this same error on my x86 Windows XP box. I need to sort out what the problem is.
It was just the version of make included in that package. I've updated the package and am uploading it right now. (Should be ready in a few minutes.) Note bug 500070, however, if you're building on x64.
You need to log in before you can comment on or make changes to this bug.