Last Comment Bug 415116 - Chrome urls not "skin" or "locale" are assumed to be "content"
: Chrome urls not "skin" or "locale" are assumed to be "content"
Status: RESOLVED FIXED
: verified1.8.1.12, verified1.8.1.13
Product: Core
Classification: Components
Component: General (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Daniel Veditz [:dveditz]
:
:
Mentors:
chrome://browser/fakesomething/browse...
Depends on: 413250 417584
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-31 10:22 PST by Daniel Veditz [:dveditz]
Modified: 2008-03-24 13:43 PDT (History)
7 users (show)
dveditz: blocking1.9?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Daniel Veditz [:dveditz] 2008-01-31 10:22:31 PST
In nsChromeRegistry::ConvertChromeURL chrome URIs with a "provider" that is not "skin" or "locale" are assumed to be "content" and are mapped to the registered content baseURI. I haven't found any fun things to do with this but it worries me.

nsChromeRegistry::Canonify does require "content" to fixup chrome URIs that don't have a path (short forms chrome://browser/content/)
Comment 1 Daniel Veditz [:dveditz] 2008-01-31 10:28:11 PST
benjamin, neil: either of you know a good reason for this (like perf)? If not I'll just fix it. Haven't checked the old mozilla/rdf/chrome to see if it has the same problem, this is based on mozilla/chrome
Comment 2 Benjamin Smedberg [:bsmedberg] 2008-01-31 10:29:35 PST
I did this in the new chrome registry because it was that way in the old registry and I didn't know what would break. I'm not sure it's a big deal, so... whatever.
Comment 3 Daniel Veditz [:dveditz] 2008-01-31 14:29:42 PST
I rolled this fix into bug 413250.
Comment 4 Daniel Veditz [:dveditz] 2008-01-31 18:01:22 PST
Fix checked in with bug 413250
Comment 5 Al Billings [:abillings] 2008-03-24 13:43:42 PDT
This was verified with bug 413250 then.

Note You need to log in before you can comment on or make changes to this bug.