JavaScript Error: "this._folderTree is undefined

RESOLVED INVALID

Status

()

RESOLVED INVALID
11 years ago
9 years ago

People

(Reporter: cbook, Unassigned)

Tracking

Trunk
Firefox 3 beta4
x86
Mac OS X
Points:
---
Bug Flags:
in-litmus ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Created attachment 300690 [details]
screenshot of the empty ui

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b3pre) Gecko/2008013108 Firefox/3.0b3pre

Steps to reproduce:
-> Go to any page of your choice
-> Click the star to bookmark a page
-> Click on Edit Bookmark
-> UI is empty and no folder displayed, see screenshot
-> JS error from the Debug build

* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "'[JavaScript Error: "this._folderTree is undefined" {file: "chrome://browser/content/places/editBookmarkOverlay.js" line: 411}]' when calling method: [nsIDOMEventListener::handleEvent]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "<unknown>"  data: yes]

This happen every time on the first try to create a bookmark
Flags: in-litmus?
Flags: blocking-firefox3?
(Reporter)

Comment 1

11 years ago
marking this as invalid, since the bookmark feature via the star has changed.

Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
Flags: blocking-firefox3?
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.