Inside table, a "height: 100%; overflow: auto" block isn't getting a scrollbar when it should (?)

RESOLVED DUPLICATE of bug 210657

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 210657
10 years ago
9 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Created attachment 300764 [details]
reduced testcase 1

Filing this bug for testcases 4 and 5 on bug 402629, which are a separate issue from the problem in that bug.

Those testcase are: attachment 288704 [details] (testcase, missing scrollbar in inner div)
                    attachment 289709 [details] (reference-ish case, scrollbar present)

I'm also attaching a much-reduced testcase.   In IE7, its blue box is 200px high and gets a scrollbar; in FF2 / FF3 / WebKit, the blue box grows to hold all the content, and it doesn't have a scrollbar.

I'm not sure what the desired behavior is here, and I'm not yet convinced yet that this is a bug in Firefox.  This may just be a case where IE does their own thing.

Comment 1

10 years ago
Opera 9.5 beta, Safari 3.04 and the latest WebKit build (r29890) constrain the height of the table-cell to 200px here (0S X 10.5.1).
(Reporter)

Comment 2

10 years ago
Ah, ok -- I'd tested WebKit using Konqueror 3.5.8, which matches Firefox.  WebKit must've changed/fixed this behavior since whatever version Konqueror 3.5.8 uses.

Comment 3

10 years ago
Older versions of Safari (2.0.x) also failed this (and older versions of Opera, like 9.2x).

That said, there are multiple mentions of this bug in Bugzilla, like bug 210657.

Comment 4

9 years ago
(In reply to comment #3)
> That said, there are multiple mentions of this bug in Bugzilla, like bug
> 210657.

Sorry, one bug is enough.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 210657
You need to log in before you can comment on or make changes to this bug.