There seem to be several ways to corrupt the bookmarks manager

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
P3
major
RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: Martijn Wargers (dead), Unassigned)

Tracking

({dataloss})

Trunk
x86
Windows XP
dataloss
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Created attachment 300772 [details]
bookmarks file

To reproduce this bug:
- Open Bookmarks Manager (Library)
- Try to delete all folders and bookmarks by pressing the del key. Some folders don't seem to disappear.
- Close the bookmarks manager
- Do an import of a bookmarks file (for example the one I attached here).


Expected result:
- The imported bookmarks should show up in the bookmarks manager.

Actual result:
- The imported bookmarks don't show up in the bookmarks manager.
Flags: blocking-firefox3?
(Reporter)

Comment 1

10 years ago
Hi Dietrich, this is what I was talking about.
It seems to happen because of trying to delete on folders that don't seem to delete at first, but when you reopen the Bookmarks Manager, are gone.
Keywords: dataloss
Flags: blocking-firefox3? → blocking-firefox3+

Updated

10 years ago
Priority: -- → P3
We've done a bunch of changes, can you retest and renom here?
Flags: blocking-firefox3+
this actually WFM
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a2pre) Gecko/20090810 Minefield/3.6a2pre
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.