Closed Bug 415204 Opened 12 years ago Closed 12 years ago

Feed doesn't work

Categories

(Firefox :: Bookmarks & History, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 381357

People

(Reporter: polidobj, Unassigned)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

Attached file current feed contents
This feed works in FF2.  The preview works in the current nightly but a livemark does not.

After restarting the browser I get these errors:

Error: [Exception... "'Container view not found' when calling method: [nsINavHistoryResultViewer::itemInserted]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame :: file:///C:/Documents%20and%20Settings/Brian%20Polidoro/Desktop/cairo/firefox/components/nsLivemarkService.js :: LS_insertLivemarkLoading :: line 558"  data: no]
Source File: file:///C:/Documents%20and%20Settings/Brian%20Polidoro/Desktop/cairo/firefox/components/nsLivemarkService.js
Line: 558

Error: [Exception... "'Container view not found' when calling method: [nsINavHistoryResultViewer::itemChanged]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame :: file:///C:/Documents%20and%20Settings/Brian%20Polidoro/Desktop/cairo/firefox/components/nsLivemarkService.js :: LLL_onStopRequest :: line 955"  data: no]
Source File: file:///C:/Documents%20and%20Settings/Brian%20Polidoro/Desktop/cairo/firefox/components/nsLivemarkService.js
Line: 955

Error: [Exception... "'Container view not found' when calling method: [nsINavHistoryResultViewer::itemRemoved]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame :: file:///C:/Documents%20and%20Settings/Brian%20Polidoro/Desktop/cairo/firefox/components/nsLivemarkService.js :: LLL_onStopRequest :: line 955"  data: no]
Source File: file:///C:/Documents%20and%20Settings/Brian%20Polidoro/Desktop/cairo/firefox/components/nsLivemarkService.js
Line: 955


Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008013104 Minefield/3.0b3pre ID:2008013104
Flags: blocking-firefox3?
Component: RSS Discovery and Preview → Places
QA Contact: rss.preview → places
the livemark does not work, but i don't get errors on restart...

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008013104 Minefield/3.0b3pre
The livemark not working is just bug 381357, since it's served as text/html and we're currently confused by that.
Hmmm I know about that bug.  When I'm at the feed preview I look at page info and it doesn't say text/hmtl.  It says application/xhtml+xml.  What's up with that?  
Attachment #300817 - Attachment mime type: application/octet-stream → text/html
Attachment #300817 - Attachment mime type: text/html → application/xhtml+xml
Wow now with the attachment set to application/xhtml+xml I get 33 of those errors.  The feed works that way though.  

The three errors above I got when subscribing to the real feed in the URL field.  

Also with a clean profile I changed both javascript.options.showInConsole and javascript.options.strict to true.  I figure that's standard for looking at problems like this.  And I made sure that after restart that the feed tries to load by using 'Reload Live Bookmark' to get the errors.
Page info only knows what's actually loaded in the <browser>, which is
subscribe.xhtml, the chrome application/xhtml+xml page into which FeedWriter.js
stuffed the feed content. It's always been like that, so I'd think there's an
(unfixable) bug filed for it, but that's not what the feed's being served as - for that you need LiveHTTPHeaders, or wget, or something like http://www.rexswain.com/httpview.html
Status: NEW → RESOLVED
Closed: 12 years ago
Flags: blocking-firefox3?
Resolution: --- → DUPLICATE
Duplicate of bug: 381357
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.