Gmail saved with a .com extension, not a .html one

RESOLVED WORKSFORME

Status

()

Firefox
File Handling
RESOLVED WORKSFORME
10 years ago
5 years ago

People

(Reporter: bz, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

BUILD: Current trunk Firefox

STEPS TO REPRODUCE:
1)  Log into gmail at http://gmail.com
2)  Make sure you're using the "newer version" thing (if needed, click the link
    next to the "Help" link on the top right corner).
3)  File > Save Page As...
4)  Make sure the folder you're saving to is the Desktop and that you're using
    the filename Firefox prompted you with.
5)  Click OK.
6)  Double-click the file that got saved to the desktop.

ACTUAL RESULTS: Page saved with a filename like "Gmail - Inbox - username@gmail.com".  Double-clicking it asks what app to use to open .com files.

EXPECTED RESULTS:  As on Linux, save as "Gmail - Inbox - username.gmail.com.html" or something else that will make sure the file is associated with the default web browser.

NOTE: I see the same behavior with Seamonkey on Mac, so this might be either a core issue or copy/paste stuff... I don't really know for sure offhand.

Comment 1

6 years ago
In Fedora 16 its name is
"Gmail - Inbox (10) - username@gmail.com.html"

Is this still an issue for you or can this be closed as WORKSFORME / obsolete?

Updated

5 years ago
Flags: needinfo?(bzbarsky)
> In Fedora 16 its name is
> "Gmail - Inbox (10) - username@gmail.com.html"

This bug was never present on Linux; see comment 0.

I can't reproduce this on Mac either, but I bet the site has changed a bazillion times since then....
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(bzbarsky)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.