browser.download.lastDir will hang if the last dir is faulty

VERIFIED DUPLICATE of bug 254380

Status

()

VERIFIED DUPLICATE of bug 254380
11 years ago
10 years ago

People

(Reporter: erikrana, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

This might be in WinXP handling of windows networking. But Firefox keeps on hanging hard so some handling should be in Firefox.

I used to save some images and other things on a friends laptop that i connected to my homenetwork via windows networking..
Therefore i got the path \\192.168.0.5\test in browser.download.lastDir.
When the path does not exsist it hangs the app probably due to the **** windows networking..But somehow it must be able to recover in a better way then hacking about:config .


Reproducible: Always

Steps to Reproduce:
1. Save some images on a shared folder on another machine using windows networking.
2.Remove that machine.
3.Use right-click "save image as" and watch Firefox become unresponsive.
Actual Results:  
Firefox hang, killed the process with task manager and restarted it..


Expected Results:  
Handle path's that does not exsist via windows networking better..
Offer a solution to the user that the path is not availabe and offer to save somewhere else..
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 254380
Verified dup
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.