Save password dialog has confusing button titles

VERIFIED FIXED in M17

Status

SeaMonkey
Passwords & Permissions
P3
minor
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Matt Behrens, Assigned: Stephen P. Morse)

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
BuildID:    2000060420

When logging in to slashdot.org, and logging in, Mozilla offers to save the 
username and password for the site.  However, the dialog that it presents looks 
like this:

  Confirm

  Do you want to remember your user name and password?

  Stored values are not password protected.

  [OK <-|] [Never for this site] [Cancel]

The appropriate button values should be:

  [Yes] [Never for this site] [No]

It could be argued that [OK] is permissible, but [Cancel] is right out here.  
Hitting [Cancel] in any context should cancel the entire action (meaning 
bringing you back to the home page without even _using_ the password).

Steps to Reproduce:
1. Visit http://slashdot.org/ (or, I imagine, other similar sites.)
2. Log in with a registered nickname/password.
3. Behold the dialog box. :-)
(Assignee)

Comment 1

18 years ago
This is definitely a regression -- the buttons had always said yes/no/never.  
I'll investigate immediately.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → M17
(Assignee)

Comment 2

18 years ago
Problem was caused by changes made over the week-end to commonDialogs.js for 
"code cleanup".  I have a fix in hand.
(Assignee)

Comment 3

18 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
verif using opt comm bits on all/all 2000.06.07.08/10.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.