Firefox does NOTHING when it try to open a .ogg file

RESOLVED INVALID

Status

()

Firefox
File Handling
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: Sergio, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; pt-BR; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; pt-BR; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

Actions for downloads is limited, you can only remove actions but cannot add for instance it would be good if I could add manually .ogg -> open with plugin X...
The bug is that Firefox does nothing... at least it should ask for a plugin, but it doesn't happen. In my machine I have VLC and Windows Media Player, both can play ogg audio files (I tested) but Firefox doesn't give me a chance to tell it at least to open that file with x program.

Reproducible: Always

Steps to Reproduce:
1. Visit http://upload.wikimedia.org/wikipedia/commons/c/c4/De-zeitgeist.ogg
2. 
3.
Actual Results:  
No audio is played and no plugin is asked

Expected Results:  
Firefox should ask to install a plugin

In order to Windows Media Player to manage ogg files, I needed to download and install the ogg codecs by a program found at internet.

http://www.illiminable.com/ogg/downloads.html
(Reporter)

Comment 1

10 years ago
Internet Explorer opens VLC program and you can play the ogg audio file, so it's so bad that Firefox does nothing at all.
It can't ask for a plugin because a plugin has to register the accepted mime-types and yes, we have a bug for that (Enhancment request for plugin manager)
This works for me with Firefox2.0.11 and Seamonkey trunk after i removed the VLC plugin. I had to remove the VLC plugin because it seem to be buggy with this ogg file. Firefox and SM asks what to do with this file and i can assign it to a Helper application.
And Firefox only asks for a plugin if a Media File is called with object or embed tag inside a HTML, without it should ask you for a helper application.

Please type "about:plugins" as URL and look if you have an entry for application/ogg and also look in Tools/Options/content/File Type[Manage]
(Reporter)

Comment 3

10 years ago
Yes, you are totally right.

Uninstalling VLC, Firefox does ask for a suitable plugin, as it was supposed to do.

I apologize for guilting Firefox when the buggy in the story was VLC plugin (and software - I tried to open that URI directly with VLC (HTTP field) and no sound was produced, although the time slider seemed to play something...)

Thanks a lot, I couldn't know without uninstalling VLC...

As all we know: Firefox® is great. It rules!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

10 years ago
[quote] <i>Please type "about:plugins" as URL and look if you have an entry for
application/ogg and also look in Tools/Options/content/File Type[Manage]</i>[/quote]

When I saw the bug I looked into the file types manager and there was no ogg in that. Vlc and ogg mime both appeared in the about:plugins list but ogg file tipe was not in the list. Probably another vlc plugin bug.

Fortunatelly, Firefox has nothing with this problem. It was proved to be VLC fault. Thanks again.
You don't need to uninstall VLC, just rename the plugin .dll and Firefox can't find it after a restart of Firefox.

For VLC rename c:\program Files\Video Lan\VLC\npvlc.dll to for example npvlc.dl_

That you don't see all plugin in the Helper Applications list is a Firefox problem but you can't really manage plugins there. We have a bug about a real Plugin manager (I don't know the bug# at the moment)
You need to log in before you can comment on or make changes to this bug.