Not all events from ICS file are show in main calender and event view.

RESOLVED WORKSFORME

Status

Calendar
Calendar Views
--
major
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Michael Borvang, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; da; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Missing events i views from ICS file.

Not alle events is shown in the main calender window and in the little event window where you can sort events by date, name and so on.

I have attached the ICS file in bug 413099.

Events like "lille juleaften" and "juleaften" is not shown.

This is tested witn month view and Sunbird 0.8pre from 27. januar 2008.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

10 years ago
Works for me using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12pre) Gecko/2008020220 Calendar/0.8pre.

I imported the .ics file in question (attachment 300986 [details] in Bug 413099) into local storage calendar and subscribed to it as a remote .ics calendar and the two events mentioned in comment #0 are displayed in the main calendar view and the unifinder (after changing the filter of course).

Please provide detailed Steps to Reproduce starting with a new profile.
(Reporter)

Comment 2

10 years ago
Hi Stefan,

I used my profil from sunbird 0.7 (the profile started using Sunbird 0.3, 0.5 and now 0.7), so it is an old profil.

I have not early'er seen problems with that in any way.

Do you know of any known problems, since you do it like that, it should be possible to upgrade Sunbird or ???

Is there any settings I can check when testing ?

Comment 3

10 years ago
I use a different profile for testing. Start Sunbird with the command line parameter -P to start the profile manager <http://kb.mozillazine.org/Profile_Manager> and create a new one. If you want to test with your default profile I'd recommend to create a profile backup first.
(Reporter)

Comment 4

10 years ago
1. make a new profile
2. from the menu - file open calender file
3. select ICS file
4. press OK

Thats the way I have done it...

Comment 5

10 years ago
Still works for me using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13pre) Gecko/2008031122 Sunbird/0.8.

I changed the unifinder filter from "Events in the Next 7 Days" to "All Events" to see the events in question. Did you do this?

I switched the month view to December 2007 or to December 2008 to see the events in question.  Did you do this?

Please provide *detailed* steps (i.e. include every mouse click, every menu selection, every preference change etc.) to reproduce the issue.

Please also clarify the effected platform: This bug is filed for Windows XP but the browser that was used reports Mac OS X. 
(Reporter)

Comment 6

10 years ago
As I said, I did test on Windows XP and not Mac OS X.

I retested on Sunbird 0.8 RC1 US and the bug is not in this version, so it has been fixed by som of the changes there have been made.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 7

10 years ago
We mark a bug as WORKSFORME, if we don't have a corresponding checkin to point to.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.