Can't do multiple select of IMAP messages in subject pane

VERIFIED FIXED

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: kinmoz, Assigned: David Hyatt)

Tracking

({regression})

Trunk
x86
Windows NT
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dogfood-])

(Reporter)

Description

18 years ago
In my 06/05/00 mozilla Win32 build, I can't use shift-click to select a range of
messages in the subject pane.

If I have a selected message, then shift click on another message several rows
down, it looks like it selects everything in between, you can actually see it
hilite everything. But then before the operation is done, it unselects
everything and then selects just the last thing I clicked on.
(Reporter)

Comment 1

18 years ago
Nominating for dogfood since this is forcing me to click on each message,
causing a load of the message, and press delete. This is pretty painful over a
slow connection.

Cc'ing hyatt@netscape.com since it may be tree related?
Keywords: dogfood, regression

Comment 2

18 years ago
so, is this happening before you do the operation or after you do the operation 
(such as delete)?  I have a build from this morning and I can shift select items 
with no problem and also delete multiple items with no problems.

If it's happening before you try to do something, i.e, the act of shift 
selecting causes this problem, then my guess is it would be a tree bug.
(Reporter)

Comment 3

18 years ago
It happens before, while I'm trying to do the shift-click.

Comment 4

18 years ago
ok. then my guess is that this is a tree bug.  reassigning to hyatt. But as I 
mentioned, I'm unable to reproduce in  my current build so I don't really know 
if this is a tree bug.
Assignee: putterman → hyatt
(Reporter)

Comment 5

18 years ago
Hmmmm, I just restarted mozilla and tried this again, and now it works.

It may be tree selection wierdness. I also notice that you can't shift-click 
more than once. That is you select a message, shift-click on message #2 several 
rows below, then shift-click on message #3 several rows below that. What I 
expect to happen is that everything between the initial message and message #3 
to be selected ... instead, only messages between message #2 and #3 are 
selected.

Comment 6

18 years ago
Marking as WorksForMe per kin's last comments.  Please mark Verified if still ok
with todays build.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
Whiteboard: [dogfood-]
(Reporter)

Comment 7

18 years ago
I'm reopening this bug because it still needs to be investigated!

Just because it worked once after I restarted doesn't mean there isn't a bug.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Updated

18 years ago
QA Contact: lchiang → laurel
(Assignee)

Comment 8

18 years ago
Unable to reproduce the deselection problem.  I already have a bug on the 
incorrect shift+click behavior, so marking this bug fixed.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 9

18 years ago
I am also unable to reproduce the deselection problem. Marking this verified.
The bug hyatt was referring to about incorrect shift+click behavior in extending
the selection area, i.e. selecting from last click not first, is covered in bug
#30377.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.