Flag->snapshot() calls Flag->match() with attach_id being undefined when editing bug flags

RESOLVED FIXED in Bugzilla 3.2

Status

()

RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: LpSolit, Assigned: LpSolit)

Tracking

({regression})

3.1.3
Bugzilla 3.2
regression
Bug Flags:
approval +

Details

Attachments

(1 attachment)

(Assignee)

Description

11 years ago
Created attachment 301385 [details] [diff] [review]
patch, v1

When editing bug flags, attach_id is undefined when match() is called by snapshot(), making errors to be thrown by Object->match():

process_bug.cgi: Use of uninitialized value in string eq at Bugzilla/Object.pm line 183.

We should set attach_id to IS_NULL instead. This is a regression due to bug 413772. r+'ing myself as module owner.
Attachment #301385 - Flags: review+
(Assignee)

Updated

11 years ago
Flags: approval+
(Assignee)

Comment 1

11 years ago
Checking in Bugzilla/Flag.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Flag.pm,v  <--  Flag.pm
new revision: 1.92; previous revision: 1.91
done
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Summary: Flag->snapshot() calls Flag->match() with attach_id being undefined → Flag->snapshot() calls Flag->match() with attach_id being undefined when editing bug flags
You need to log in before you can comment on or make changes to this bug.