Registration process fails, probably because rejecting email address

RESOLVED FIXED

Status

RESOLVED FIXED
11 years ago
9 years ago

People

(Reporter: paul.0000.black, Assigned: oremj)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9b3pre) Gecko/2008020419 Minefield/3.0b3pre
Build Identifier: 

Registering on https://services.mozilla.com fails with "Something has gone wrong". Using an email address without a + succeeds (+ is valid in the local part of the email address).

Probably could do with a more informative error message.



Reproducible: Always

Steps to Reproduce:
1. Go to https://services.mozilla.com
2. Try to register with an email address with a + in it.

Actual Results:  
Displays "Something has gone wrong"

Expected Results:  
Account is created.

Comment 1

11 years ago
Hey Justin, this is a problem with the registration code.

Comment 2

11 years ago
oremj - can you take a look?
Assignee: nobody → oremj
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

11 years ago
This is actually broken at the ldap level. Aravind, do you know why ldap won't allow e-mail address with "+" in them?  Any idea how to fix it?
Assignee: oremj → aravind
+ signs are allowed, but the problem is that they need to be properly escaped when you create new entries.  They also pose problems with the search syntax when you search for stuff.

If you insist on being all RFC compliant and everything, and want to allow + signs, here is how a sample ldap_add should look.  Note that only the dn should be escaped.  The mail entry in the ldif should NOT.

dn: mail=homer\+blah@mozilla.com,c=hoho,dc=mozilla
uidNumber: 1090
homeDirectory: /home/homer
loginShell: /bin/bash
path: /home/homer
mail: homer+blah@mozilla.com
objectClass: posixAccount
objectClass: person
uid: homer
gidNumber: 567
sn: Blah
cn: Homer
userPassword: {SSHA}lksda3209uhelk23jskdjh293u4fesdf
Assignee: aravind → oremj
(Assignee)

Comment 5

11 years ago
Fixed.  Thanks for figuring that out.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 6

11 years ago
Thanks!

Updated

9 years ago
Component: Weave → General
Product: Mozilla Labs → Weave
Target Milestone: -- → ---
QA Contact: weave → general
You need to log in before you can comment on or make changes to this bug.