nslSound.play problem when playing a wav file

RESOLVED DUPLICATE of bug 534033

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 534033
10 years ago
8 years ago

People

(Reporter: Francois Logier, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.1.11) Gecko/20071209 Firefox/2.0.0.11
Build Identifier: version 2.0.0.9 (20071117)

I wish to have a sound file played when a new mail arrives in my inbox

Reproducible: Always

Steps to Reproduce:
1. Use KDE
2. In the General properties panel, click on play a sound when a mail arrive
3. Select a wav file
Actual Results:  
In error consol :
Erreur : uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsISound.play]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://messenger/content/preferences/general.js :: anonymous :: line 141"  data: no]

Expected Results:  
Sound played
(Reporter)

Comment 1

10 years ago
Created attachment 301474 [details]
Wav file
(Reporter)

Updated

10 years ago
Version: unspecified → 2.0

Comment 2

10 years ago
WFM on trunk. (Didn't try that actual wav, did you mean it's only that or wav files in general.)

Comment 3

8 years ago
Francois, do you still see this?  dup of bug 534033?
Whiteboard: dupme?
(In reply to comment #0)

I have downloaded the attached file and I have been following all the steps to make Thunderbird play WAV files when a new mail arrives.

I have to tell you that with your WAV file, at least for me it works correctly, but I have one WAV file that my GNOME is able to play and Thunderbird 3.1b2pre only pay clicks and noise.

So here I have detailed all the steps:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.2pre) Gecko/20100309 Lanikai/3.1b2pre 

Name=Thunderbird
Version=3.1b2pre
BuildID=20100309031442
SourceRepository=http://hg.mozilla.org/comm-central
SourceStamp=4d49469ed771
Copyright=Copyright (c) 1998-2010 mozilla.org
ID={3550f703-e582-4d05-9a08-453d09bdfdc6}

I'm using GNOME 2.28.1 over Ubuntu 9.10

1.- In the General properties panel, click on play a sound when a mail arrive.
2.- Select a wav file.
3.- Use the play button to hear the wav file.
    The one used in this bug works without problem.
    The one that I have attached now, only makes noise.

Cheers!
Created attachment 431628 [details]
This wav file is only noise when Thunderbird tries to reproduce it

This wav file is only noise when Thunderbird tries to reproduce it.
Dupe of bug #534033 : both errors raise the same error in error console.

(dupe this also if is the oldest, but isn't a problem)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupme?
Duplicate of bug: 534033
You need to log in before you can comment on or make changes to this bug.