bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Can't open new bookmark in sidebar (webpanel) after closing it.

RESOLVED DUPLICATE of bug 406697

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 406697
11 years ago
11 years ago

People

(Reporter: max1million, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Firefox 3 Beta 2 http://www.mozilla.com/products/download.html?product=firefox-3.0b2&os=linux&lang=en-US

Opening sidebar bookmarks (webpanel) works till the webpanel is closed. Then I can't get it to open a different bookmark in sidebar (only the last). Some errors had to do with removing a listener when closing sidebar and getting the content document when reopening sidebar in browser.xml. No .contentDocoment or .contentWindow of sidebar. Restart FF it works. 


Reproducible: Always

Steps to Reproduce:
1.Open sidebar bookmark.
2.Close sidebar.
3.Try to open different sidebar bookmark.
Actual Results:  
It opens last one, from first time closing.

Expected Results:  
Open new bookmarked page.

Bookmarks panel and History panel still worked. Any that open directly in sidebar. Seems to be a problem with using the browser element and it's binding inside the web-panels.xul (inside the sidebar's browser). I forget the exact errors (see details) didn't write them down. On win 98 now to get online FF3 don't work. 

Component selected was bookmarks but it could also be browser.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 406697
You need to log in before you can comment on or make changes to this bug.