Remove Bookmark button on star UI looks misplaced

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
11 years ago
a year ago

People

(Reporter: stevee, Unassigned)

Tracking

({uiwanted})

Trunk
uiwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008020501 Minefield/3.0b4pre ID:2008020501

I don't know why, but the Remove Bookmark button feels odd to me - out of place. Maybe it would be better down with the Cancel and Done buttons, or maybe placed some other place, or just better spaced and situated in its current area.
(Reporter)

Comment 1

11 years ago
Created attachment 301504 [details]
star UI with Remove Bookmarks button

Updated

11 years ago
Keywords: uiwanted
OS: Windows XP → All
Hardware: PC → All
(Reporter)

Updated

11 years ago
Blocks: 393509
I made a mock-up of how the Remove Bookmark button would look on Gnome if it were at the bottom-left of the dialogue: see attachment 302400 [details] and bug 393509 comment 122.
(Reporter)

Comment 3

11 years ago
Created attachment 305500 [details]
I was playing around with a mockup too :)
Alex, are there any plans for that bug?
my proposal for this was attachment 302398 [details]
Getting everything lined up with equal padding will probably help some.  We might want to consider an etch line between the top section and the controls, in the same general direction as Dao's mockup. A big difference in contrast doesn't really seem to directly reference other interfaces in XP (although these panels are bit strange to begin with), and I'm not sure how we would adapt it to Vista.  I agree that things look misaligned as they currently are. 
Should this have any of the [polish] keywords? ([polish-hard][polish-visual]) Or does a final design have to be decided upon first? 

FWIW I favour placing the remove bookmark button at the bottom of the dialogue similar to the attachment in comment 2. This also has the effect of making the whole dialogue wider which improves its overall appearance.
I would like us to address this with proper spacing, alignment, and half height buttons, similar to the original design and our current appearance on OS X.

Comment 9

10 years ago
I notice a bug in my Firefox 3.5, in which the "Remove Bookmark" button is blank. That is there is not text written in it. This wasn't the case in the previous version of Firefox.

I guess this has got something to do with one of my add-ons, because I am facing the same problem on both of my computers (Xp & windows 7). However, I am not able to narrow down to which one is creating the issue. It could possibly be Xmarks (as it has started behaving awkwardly anyways).

Comment 10

10 years ago
(In reply to comment #9)
> I notice a bug in my Firefox 3.5, in which the "Remove Bookmark" button is
> blank. That is there is not text written in it. This wasn't the case in the
> previous version of Firefox.
> 
> I guess this has got something to do with one of my add-ons, because I am
> facing the same problem on both of my computers (Xp & windows 7). However, I am
> not able to narrow down to which one is creating the issue. It could possibly
> be Xmarks (as it has started behaving awkwardly anyways).

Nimish, that is completely unrelated to what this bug is out.  Please read https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

Now, there is only one related bug that is marked WFM because I couldn't get and further information from the reporter but you should never file a bug without checking in safe mode or with your extensions disabled.  Please open a new bug if you can reproduce in safe mode.
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
Somewhere along the way, we re-organised the bookmark panel so that the cancel button has been replaced by remove bookmark & hence it looks a lot better now. Not sure what changed it, so marking as WFM.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.