In forwarding the signature file gets appended above the text

VERIFIED WORKSFORME

Status

MailNews Core
MIME
P3
normal
VERIFIED WORKSFORME
18 years ago
9 years ago

People

(Reporter: marina, Assigned: rhp (gone))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
**** observed with 2000-06-05-08 M16 build ****
Steps to reproduce:
-create a signature file, check the appropriate box for its location on the 
Account Settings;
-compose a new mail, send it and get it;
-select the received message and forward it to yourself;
-get it and note:
//the signature file is above the forwarded message;
expected : should be appended at the bottom

Comment 1

18 years ago
over to rhp. this is a nsbeta3 polish bug so we can pass on it till beta3.
Assignee: mscott → rhp
Component: Mail Back End → MIME
Keywords: nsbeta3
Target Milestone: --- → M20

Comment 2

18 years ago
Note, that we won't quote anything after a plaintext sig delimiter after bug
9202 is fixed (RSN).
Anyway, I think, this is a MUSTFIX for final.

Updated

18 years ago
QA Contact: lchiang → esther
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 3

18 years ago
I could be wrong here, but I think this is working correctly. Please let me 
know if I am seeing things, but the sig for user seems to be below the 
Forwarded message.

- rhp
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Updated

17 years ago
QA Contact: esther → laurel

Comment 4

17 years ago
Using sept 20 commercial builds, the signature is appended at bottom if
forwarding pref is set to forward inline.  I don't know if this is correct,
because it looks odd -- my signature is at the end of someone else's message
(the forwarded one) while my text (if I added any) is before the message. This
particularly looks weird when there is a signature with the message I'm
forwarding.  I would expect my signature to stay with my text.  

If the pref is set to forward as an attachment, the signature will appear before
the attachment (which also is displayed in msg pane if of attachment type is
displayable).

I do not know what is correct for signatures when forwarding inline.  I did  a
few 4.x tests and didn't get consistent results.  Sometimes it added signature,s
ometimes not.

I think I'll read the bug mentioned by Ben Bucksch and try to seek out some
other info before marking this verified.

Comment 5

17 years ago
Well, I'm guessing this is OK.  Since we're not quoting (we have no forward
quoted option in 6.0) the inline behavior shouldn't strip a previous signature I
think. 
All is ok, except for the case of HTML forwarding inline when there is a
previous signature -- the signature of the forwarder gets added, but is mixed
among the previous signature... this is bug 43829 (written against reply
quoting, but I'll add a forwarding case comment to it).

Calling this bug verified worksforme.
Status: RESOLVED → VERIFIED

Comment 6

17 years ago
laurel, removin sigs is a feature that just doesn't exist for HTML msgs. That's
what bug 43829 is about. But if sigs are anyhow messed up (and you seem to
describe such a case), this is a bug and should be filed extra.
(Reporter)

Comment 7

17 years ago
I don't feel comfortable veryfying this bug as worksforme because in case of the 
HTML aattchment the signature is above the attachment itself

Comment 8

17 years ago
marina, you mean, if you forward a msg as attachment, the sig should appear at
the bottom, under the appended msg? This is impossible. Think of the msg as a
map with two documents: the text you typed (including the sig), and the
forwarded msg.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.