If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

%20 added where space should be when I click "see all results" in Get Add-ons search

VERIFIED DUPLICATE of bug 414595

Status

()

Toolkit
Add-ons Manager
VERIFIED DUPLICATE of bug 414595
10 years ago
9 years ago

People

(Reporter: Brian Bermingham, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008020604 Minefield/3.0b4pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008020604 Minefield/3.0b4pre

When searching for add-ons in the add-on manager, the lick "see all results" substitutes a space with %20

Reproducible: Always

Steps to Reproduce:
1. Open up Add-ons manager
2. Click Get Add-ons tab
3. Search for add-on with a space in the name, e.g. Mr Tech
4. Click "See all results link"
5. When the new tab opens in Minefield/Firefox no results will be shown, the value in the "Search Add-ons" textbox on this page will be, mr%20tech, with the URL - "https://addons.mozilla.org/en-US/firefox/search?q=mr%2520tech"
Actual Results:  
No results for "Mr Tech" as %20 replaces the space between Mr and Tech

Expected Results:  
List of add-ons matching the search criteria - "Mr Tech"

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 414595
Verified dup
Status: RESOLVED → VERIFIED
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.