Add RLM To default search engines description

RESOLVED FIXED

Status

Mozilla Localizations
he / Hebrew
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: tomer, Assigned: tomer)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

10 years ago
Some of the search engines provided with Hebrew Firefox contains Hebrew description, and this make them appear wrong when using English locale. 

Currently, the Wikipedia Search plugin appear as "ויקיפדיה (עברית)" instead of "ויקיפדיה (עברית)‏" (source: "Wikipedia (Hebrew)[RLM]"). 

Assigning to myself.
(Assignee)

Comment 1

10 years ago
Created attachment 302289 [details] [diff] [review]
Adding RLM to wikipedia search engine

Make sure to view the file with unicode viewer capable of showing hidden control characters.
(Assignee)

Comment 2

10 years ago
Created attachment 302290 [details]
wikipedia-he.xml    revision 1.4
(Assignee)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 3

10 years ago
Changes to search engines should go through review, both from Mic, and technically from me or gavin.

Updated

10 years ago
Blocks: 412273

Updated

10 years ago
Whiteboard: needs-gavin
The best fix for the problem is to set "dir: auto" for the input field.  I'm not sure if it works in Fx3.0, so CCed smontagu.
(Assignee)

Comment 5

10 years ago
By the way - The same should also be added to the Start-Menu shortcuts on Windows. Currently it is "Firefox (Safe mode), which is translated to "Firefox (מצב בטוח)", and on English Windows UI the bracket appear in the wrong order.
The change made by attachment 302289 [details] [diff] [review] looks fine to me.
Whiteboard: needs-gavin
(Assignee)

Updated

10 years ago
Summary: Add RLM To search engines description → Add RLM To default search engines description

Comment 7

10 years ago
i'm ok with suggested change as well

Updated

10 years ago
Blocks: 415597

Updated

10 years ago
No longer blocks: 412273

Updated

10 years ago
Blocks: 412273

Updated

9 years ago
No longer blocks: 415597

Updated

9 years ago
Blocks: 285718
You need to log in before you can comment on or make changes to this bug.