Closed Bug 416005 Opened 13 years ago Closed 13 years ago

Order of web feed readers broken in Fx3

Categories

(Firefox Graveyard :: RSS Discovery and Preview, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: Pike, Assigned: philor)

Details

(Keywords: late-l10n, regression)

Attachments

(1 file)

In bug 415475, Hasse reports that "It seems the ordering in UI is done as 1,0,2", and that matches what I'm seeing on today's nightly.

Couldn't find a duplicate, so requesting blocker status.

Mic, Mike, can you figure out a priority for this?
Flags: blocking-firefox3?
the order of Readers from Fx 2 was Bloglines, My Yahoo, Google Reader
check out: http://wiki.mozilla.org/Firefox3/L10n_Requirements#RSS_Sample

I'm not sure what's involved technically or if anything changed. We have not in recent guidelines discussions talked about order of readers explicitly and other than making things easy for localizer I don't have a strong opinion for the order beyond local language first. meaning whatever reader that is in local language could/should be offered first. but that's new relative to what's in requirements above and I wouldn't that opinion to block anything.
Attached patch Sort 'em, v.1Splinter Review
Heh. Apparently if you want things to be sorted, you have to actually sort them, not depend on an interface that makes no promises and no attempts to sort them for you. dwitte's take on the fact that they go through a hashtable in getChildList and used to come out sorted was probably about right: "sounds like you should buy a lottery ticket."

Not quite sure yet how to do a meaningful testcase, since I don't know the values and order a priori because I don't know what locale the test is running under, so it seems like I'd have to determine the right results by running a copy of the exact same code in the test, but since it's screwing over localizers, we should probably fix it first and then worry about that.
Assignee: nobody → philringnalda
Status: NEW → ASSIGNED
Attachment #301835 - Flags: review?(mano)
Comment on attachment 301835 [details] [diff] [review]
Sort 'em, v.1

r=mano, assuming they should be sorted.
Attachment #301835 - Flags: review?(mano) → review+
Comment on attachment 301835 [details] [diff] [review]
Sort 'em, v.1

Mmm, the tyranny of numbered lists.

Drivers: it's simple, I can say that for it.

And we acted like it was wanted in 2.x - pl had to get special permission to put a localized service first, es-AR got called on the carpet for messing up the approved order.

It's certainly wanted in the pl case - Bloglines still isn't localized in Polish - but I just as certainly don't know whether it's actually required in the trademark/agreement/contract sense, or whether the ordering requirements just grew up out of the technical detail of needing numbers to track which was which making it look ordered (and needing Google to not be first to not look bad because it was a Google employee writing the code).

The one non-wishy-washy argument I can make for taking it is that having the order random between uses would be awful UI, and there's no reason to believe that the current hashtable optimization that gives us 1,0,2 consistently will continue - at any time someone could  optimize it so that the order is random, and you wouldn't know where to find your reader from one subscription to the next.
Attachment #301835 - Flags: approval1.9?
Attachment #301835 - Flags: approval1.9? → approval1.9+
Flags: blocking-firefox3? → blocking-firefox3+
browser/components/feeds/src/WebContentConverter.js 1.28
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Flags: in-testsuite?
Resolution: --- → FIXED
verified fixed using : Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b4pre) Gecko/2008022005 Minefield/3.0b4pre. The feed readers are now in the order specified in Comment 1.
Status: RESOLVED → VERIFIED
Flags: in-testsuite? → in-testsuite-
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.