Test 1 fails in compiling Bugzilla::Install::CPAN and install-module.pl when Cygwin is installed

RESOLVED FIXED in Bugzilla 3.2

Status

()

Bugzilla
Testing Suite
--
minor
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Wurblzap, Assigned: Wurblzap)

Tracking

3.1.3
Bugzilla 3.2
All
Windows XP
Bug Flags:
approval +
blocking3.2 +

Details

Attachments

(1 attachment)

(Assignee)

Description

11 years ago
The testing suite's test 1 reports compilation of Bugzilla/Install/CPAN.pm to fail. In turn, this makes install-module.pl seem to fail test 1. It seems to me this is because CPAN.pm gives some output on startup ("Set up gcc environment - 3.4.4 (cygming special, gdc 0.12, using dmd 0.125)"), which probably confuses the testing harness.

Compilation for Bugzilla/Install/CPAN.pm and install-module.pl succeeds, so test 1 should report this correctly.

This may be a Windows-only issue.
Flags: blocking3.2?

Comment 1

11 years ago
Ah, the testing suite shouldn't be trying to compile anything in the lib/ directory, that's the problem. So we need to stop it from doing that.
Flags: blocking3.2? → blocking3.2+
Summary: CPAN.pm makes test 1 fail for Bugzilla/Install/CPAN.pm and, in turn, install-module.pl → test 1 attempts to compile modules in the lib/ directory

Updated

11 years ago
Assignee: zach → nobody
(Assignee)

Comment 2

11 years ago
This is not about the lib/ directory, but about Bugzilla/Install/CPAN.pm (or its dependence CPAN.pm, which emits said output when "use"d in Bugzilla/Install/CPAN.pm).

Comment 3

11 years ago
Ohhh, thank you. What version of CPAN.pm are you using?
OS: All → Windows XP
Summary: test 1 attempts to compile modules in the lib/ directory → Test 1 fails in compiling Bugzilla::Install::CPAN and install-module.pl
(Assignee)

Comment 4

11 years ago
I'm using version 1.9205.

Comment 5

11 years ago
I cannot reproduce the problem, neither on windows.bugzilla.org nor on my local Windows installation. Wurblzap says on IRC this may be related to Cygwin, despite I don't see how they could interact. Not a blocker IMO.
(Assignee)

Comment 6

11 years ago
Created attachment 310254 [details] [diff] [review]
Patch
Assignee: nobody → wurblzap
Status: NEW → ASSIGNED
Attachment #310254 - Flags: review?(LpSolit)

Comment 7

11 years ago
Comment on attachment 310254 [details] [diff] [review]
Patch

>+        if ($^O =~ /MSWin32/i
>+            && grep($_ eq $file, 'install-module.pl',
>+                                 'Bugzilla/Install/CPAN.pm')
>+           ) {

Nit: the indentation could be:

>+        if ($^O =~ /MSWin32/i
>+            && grep($_ eq $file, 'install-module.pl', 'Bugzilla/Install/CPAN.pm'))
>+        {

which is clearer IMO. r=LpSolit
Attachment #310254 - Flags: review?(LpSolit) → review+

Updated

11 years ago
Flags: approval+

Updated

11 years ago
Summary: Test 1 fails in compiling Bugzilla::Install::CPAN and install-module.pl → Test 1 fails in compiling Bugzilla::Install::CPAN and install-module.pl when Cygwin is installed
(Assignee)

Comment 8

11 years ago
Hrm, the line exceeds 80 characters now. Oh well.

Checking in t/001compile.t;
/cvsroot/mozilla/webtools/bugzilla/t/001compile.t,v  <--  001compile.t
new revision: 1.17; previous revision: 1.16
done
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.