If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

In location bar, autocomplete interferes with bookmark keyword + enter

VERIFIED DUPLICATE of bug 408723

Status

()

Firefox
Bookmarks & History
--
minor
VERIFIED DUPLICATE of bug 408723
10 years ago
10 years ago

People

(Reporter: Raphael K, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3pre) Gecko/2008020507 Firefox/3.0b3pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3pre) Gecko/2008020507 Firefox/3.0b3pre

In Firefox 2, I saved lots of bookmarks with keywords that allow me to access web sites very quickly. For example, to go to nytimes.com, I would just type "n" in the location bar and press ENTER.

In Firefox 3, I try to do the same thing. I type "n", but before I have a chance to press enter, an autocompletion list of sites appears below the location bar. This is a terrific feature, but there's a snag:

If my *mouse* happens to be hovering over where the autocompletion list has just appeared, pressing ENTER will activate the link underneath my mouse.

Firefox thinks I am intentionally pointing to the auto-complete suggestion and pressing ENTER as a natural substitute for clicking. But I really just wanted to activate the keyword in the location bar as I typed it.

One way to fix this would be to only highlight items in the autocomplete list if the mouse is moved.

Another way to fix: offer a substitute for ENTER that ignores the autocomplete suggestion highlighted by the mouse -- perhaps ALT + ENTER.

Thanks for your attention on this. Firefox 3 looks really great! Keep up the excellent work.

Reproducible: Always

Steps to Reproduce:
1. Populate your history/bookmarks so that the autocomplete list has at least one entry whose title contains the letter "n".
2. Bookmark <http://nytimes.com> with the keyword "n".
3. Bring your mouse underneath the location bar.
4. Hit ENTER.

I've used http://nytimes.com and "n", but of course any bookmark/keyword combination will work.
Actual Results:  
Firefox loads the site bookmarked in step 1.

Expected Results:  
Firefox should load the New York Times website.

I'm running Ubuntu Gutsy 7.10 on a Dell Inspiron 1521.

Comment 1

10 years ago
I can't reproduce this on Windows or Linux.  If you type "n" and follow with "enter"  the expected keyword referenced page opens.  

If you type "n"  then move your mouse at all, if it happens to be over the list, yes, it will open whatever was highlighted in the list.  That is expected.

Comment 2

10 years ago
> 3. Bring your mouse underneath the location bar.

This could be bug 408723, the entry under the cursor is selected even if the mouse is not moved.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 408723
Verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.