Datepicker in Today Pane freezes after selecting a month/year from dropdown

RESOLVED WORKSFORME

Status

Calendar
Calendar Views
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: Colin G, Unassigned)

Tracking

Lightning 0.7
x86
Windows 2000

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-GB; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Lightning 0.8pre build2008020618

Also happened in Lightning 0.7 - In Calendar mode you can select, from the calendar in the left hand pane an alternate month / year by dropping down the month or year , then select the date and the main window shows you that date. If you switch to Mail mode and open up the today pane, you can click on the drop down arrow which gives you the month calendar window, but if you try to select an alternate date from dropping down either the month or the year, that calendar window will freeze and the events and tasks window will not change to another date. If you then switch modes to either calendar or tasks , the window shows as a black square, this comes back when returning to mail mode. To clear this situation you have to close and restart thunderbird.

Reproducible: Always

Steps to Reproduce:
1.Be in Mail Mode
2.Open the Today Pane
3.Click on the dropdown arrow in the events and tasks box ( where the current date is displayed )
4.when the calendar comes up, select an alternate month or year
Actual Results:  
Poped up calendar window freezes, goes black if you change to calendar or tasks mode. 
Need to restart Thunderbird to fix.


pc is running windows 2000
(Reporter)

Updated

11 years ago
Version: unspecified → Lightning 0.7
I can confirm this behavior for the datepicker in the Agenda. But the datepicker e.g. in the event/task dialog work fine. See also existing Bug 356505 and Bug 396417.

Comment 2

11 years ago
The arrows do work, it's not the same as in those bugs. 
Status: UNCONFIRMED → NEW
Ever confirmed: true
Colin, can you confirm that this issue doesn't happen with the datepicker e.g. in the event/task dialog?
Summary: Selecting alternate Date from the Today Pane calendar drop down causes that window to lock → Datepicker in Today Pane freezes after selecting a month/year from dropdown
(Reporter)

Comment 4

11 years ago
Hello Stefan, I CAN confirm that this IS happening in the date picker in the today pane only. The date picker in the calendar mode works fine.
I have downloaded and installed the latest nightly build and fault is still present.Additionally, if you open the date picker in Today pane and select a date in the current month and year ie when you open date picker it shows february 2008,and you just select any day in that current month / year it works fine. It only goes wrong when you try to select either a different month or year
(Reporter)

Comment 5

11 years ago
(In reply to comment #3)
> Colin, can you confirm that this issue doesn't happen with the datepicker e.g.
> in the event/task dialog?
> 

Hello Stefan, I CAN confirm that this IS happening in the date picker in the
today pane only. The date picker in the calendar mode works fine.
I have downloaded and installed the latest nightly build and fault is still
present.Additionally, if you open the date picker in Today pane and select a
date in the current month and year ie when you open date picker it shows
february 2008,and you just select any day in that current month / year it works
fine. It only goes wrong when you try to select either a different month or
year

Comment 6

11 years ago
Hi, you don't need to restarst Thunderbird: click on dropdown arrow then click everywhere outside the poped up calendar window, to me this "unfreeze" the calendar and Lightning works well. 
Windows, TB 2.0.0.9, Lightning 0.8pre build2008021620

Comment 7

11 years ago
I've just tried and I see that the calendar freezes even if you click on year/month botton then, without clicking on drop down list, click on the other month/year botton.
To me this happens with the today pane datepicker AND with new event datepicker, (start and end date in New Event window) but NOT with calendar/task mode datepicker. 
In new event window, when poped up calendar is freeze, you can do everything on the window (select elements, click on working menu, click on icons) but you can't edit text (Title, Location, Description). Poped up calendar disappears clicking on drop down botton or when you save the event and/or close the window.
Windows, TB 2.0.0.9, Lightning 0.8pre build2008021620.
The issue from Comment #7 is reported as Bug 356505. 
The issue reported in this bug is only visible in the Today Pane.
Duplicate of this bug: 427722

Updated

10 years ago
Flags: wanted-calendar1.0?

Comment 10

9 years ago
Works for me, I can select different months and years from minimonth and when I select a day, minimonth disappears and today pane shows the right date.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090527 Lightning/1.0pre Shredder/3.0b3pre
Resolving as WORKSFORME per comment#10 and own test. If somebody can reproduce this issue, feel free to reopen or leave a comment.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Flags: wanted-calendar1.0?
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.