Add Search menu to History window

VERIFIED DUPLICATE of bug 41616

Status

()

Core
Document Navigation
P1
normal
VERIFIED DUPLICATE of bug 41616
18 years ago
10 years ago

People

(Reporter: johng, Assigned: don)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-] waiting for UI spec decision)

(Reporter)

Description

18 years ago
Search for History and other things should be in a separate menu like it is in 
all other components.  Please add a Search menu to the History window and move 
all history search menu items to this menu.

Are doing the same thing for bookmarks - bug 41616
(Reporter)

Comment 1

18 years ago
nsbeta3, important FCS correction.
Keywords: nsbeta3

Comment 2

18 years ago
m19
Target Milestone: --- → M19

Comment 3

18 years ago
Nav triage team: NEED INFO from QA: does searching history work at all?
Whiteboard: [NEED INFO]
(Reporter)

Comment 4

18 years ago
nav triage team:
nsbeta3+, Claudius verified that search does work.

Reassigning to Matt to load balance
Assignee: slamm → matt
Whiteboard: [NEED INFO] → [nsbeta3+]

Comment 5

18 years ago
i'll fix...
Assignee: matt → BlakeR1234
(Reporter)

Comment 6

18 years ago
You're a rock star, Blake, for fixing these two bugs (and all the others).  
You've got lots of fans here (even if you do make fun of marketing weenies).

Comment 7

18 years ago
Blake, how's the fix coming along (do you need any help from Matt or so?)

Comment 8

18 years ago
see my question in bug 41616 about what to put in these added search menus
Status: NEW → ASSIGNED

Comment 9

18 years ago
Adding Linda to cc: list.

Comment 10

18 years ago
Note that I'm fully willing to do this (not just slacking off) but I can't go 
any further without an answer from UE/design (when they have time).

Updated

18 years ago
Whiteboard: [nsbeta3+] → [nsbeta3+] waiting for UI spec decision

Updated

18 years ago
Priority: P3 → P1

Comment 11

18 years ago
Removing nsbeta3+.  Sorry, I cannot hold on to nsbeta3+ must-fix bugs if I 
don't know what to do with them.  Please feel free to re-mark nsbeta3+ once my 
questions are answered.

Thanks.
Keywords: nsbeta3
Whiteboard: [nsbeta3+] waiting for UI spec decision → waiting for UI spec decision

Comment 12

18 years ago
Blake's questions from bug 41616: These questions must be answered in order for this
bug to be fixed.

"------- Additional Comments From Blake Ross 2000-08-25 12:54 -------

Hi, sorry.  With school starting and stuff I got a bit sidetracked.  Anyways: 
what items should this menu have?  I implemented it, but right now the only 
ones that make sense to me are "Search the Web" and "Search 
Bookmarks/History".  The Find on this Page commands don't apply, nor does the 
My Sidebar Search Tab submenu really (since the window doesn't have a sidebar, 
and since that submenu's going real soon anyways - but that's the subject of a 
different bug).  There's no point in having Search Mail if we don't have it in 
the browser either.  So this menu only has two items, which makes it look 
pretty barren.  Is that what you want?"

Reassingning to German for design, can be assigned back to Blake for implementation
renominating for nsbeta3, since the plus was removed...
Assignee: blakeross → german
Status: ASSIGNED → NEW
Keywords: nsbeta3

Comment 13

18 years ago
Marking nsbeta3- while it sits in our group.  It should have nsbeta3- removed 
after it is reassigned to an engineer that can actually do the fix.
Whiteboard: waiting for UI spec decision → [nsbeta3-] waiting for UI spec decision

Comment 14

18 years ago
Bookmarks and History Search menus for Netscape 6 should have this configuration:
 
Find in Bookmarks...
Find Again...
-------------------
Common Search menu stuff (like net search)

and for history:
Find in History...
Find Again...
-------------------
Common Search menu stuff (like net search)

Forwarding to the browser team.
Assignee: german → don
(Assignee)

Comment 15

18 years ago
This is one hell of a time to be getting this bug back!  Marking as an RTM
candidate and leaving it assinged to myself to decide and investigate ...
Keywords: rtm
(Reporter)

Comment 16

18 years ago
marking as dupe or bug 41616 which has the same fix for bkmks and history


*** This bug has been marked as a duplicate of 41616 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 17

18 years ago
VERIFYING as a dupe
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.