Tagged results don't show bookmark title when matching the tag

RESOLVED FIXED in Firefox 3 beta4

Status

()

Firefox
Address Bar
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Mardak, Assigned: Mardak)

Tracking

Trunk
Firefox 3 beta4
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 -
wanted-firefox3 +
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [has fix in bug 401660])

Attachments

(1 attachment)

(Assignee)

Description

10 years ago
If you tag a page and change the title, autocomplete doesn't show the bookmarked title if you match on the tag. However, it will show the bookmark title if you match against the bookmark (and not the tag).

This will be fixed by bug 414287. I'll attach a testcase to this bug.
Flags: blocking-firefox3?
(Assignee)

Updated

10 years ago
Depends on: 414288
(Assignee)

Updated

10 years ago
Whiteboard: [has patch in bug 414287]
This does not block the final release of Firefox 3.
Flags: wanted-firefox3+
Flags: blocking-firefox3?
Flags: blocking-firefox3-
(Assignee)

Comment 2

10 years ago
Created attachment 302174 [details] [diff] [review]
testcase v1

I'll land this when bug 414287 and bug 414426 lands.
Assignee: nobody → edilee
Status: NEW → ASSIGNED
(Assignee)

Updated

10 years ago
Whiteboard: [has patch in bug 414287] → [has patch in bug 414287 and bug 414426]
(Assignee)

Updated

10 years ago
Depends on: 414426
(Assignee)

Comment 3

10 years ago
This will be fixed by bug 401660 if bug 414426 doesn't land.
Depends on: 401660
(Assignee)

Updated

10 years ago
Duplicate of this bug: 412146
(Assignee)

Updated

10 years ago
Whiteboard: [has patch in bug 414287 and bug 414426] → [has patch in bug 401660 or bug 414426]
(Assignee)

Updated

10 years ago
Blocks: 405745
(Assignee)

Comment 5

10 years ago
RCS file: /cvsroot/mozilla/toolkit/components/places/tests/unit/test_416211.js,v
done
Checking in toolkit/components/places/tests/unit/test_416211.js;
/cvsroot/mozilla/toolkit/components/places/tests/unit/test_416211.js,v  <--  test_416211.js
initial revision: 1.1
done
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Whiteboard: [has patch in bug 401660 or bug 414426] → [has fix in bug 401660]
Target Milestone: --- → Firefox 3 beta4
(Assignee)

Updated

10 years ago
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.