Closed Bug 416302 Opened 17 years ago Closed 10 years ago

xulwinopen regression from 189ms to 193ms on bldlnx03_fx

Categories

(Core :: JavaScript Engine, defect, P2)

defect

Tracking

()

RESOLVED INVALID
mozilla1.9

People

(Reporter: jag+mozilla, Unassigned)

References

()

Details

(Keywords: perf, regression)

Seems to have been the patch from bug 365851. All other changes from around that time have been backed out. Note that on the Mac tinderbox there was no winopen regression, and dhtml on the same box went down by ~3ms.
Blocks: js-propcache
Flags: blocking1.9?
Keywords: perf
OS: Linux → All
Alright you poindexters, settle down... I'm going to make Txul super-bad better.

/be
Assignee: general → brendan
Priority: -- → P1
Hardware: PC → All
Target Milestone: --- → mozilla1.9beta4
Keywords: regression
sayrer: -chrome file:/builds/tinderbox/Fx-Trunk/Darwin_8.8.4_Depend/mozilla/xpfe/test/winopen.xul
sayrer: make sure you have that file, prints to stdout
Status: NEW → ASSIGNED
Flags: blocking1.9? → blocking1.9+
Flags: tracking1.9+ → blocking1.9+
--> P2, sayrer, can you find someone to look at this?
Priority: P1 → P2
Target Milestone: mozilla1.9beta4 → mozilla1.9
Takin off blocker list for now since we are ok on txul and not sure what is left to do here.   We can follow-up in next release.
Flags: tracking1.9+
Flags: blocking1.9-
Flags: blocking1.9+
I was hoping to have time for this, but I don't. I suck, but perhaps someone will rule if I give this up.

/be
Assignee: brendan → general
Status: ASSIGNED → NEW
Flags: tracking1.9+
I'm going to go ahead and declare a 2% regression from six years ago, in a test that most certainly has completely different perf characteristics, isn't relevant anymore.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → INVALID
> I'm going to go ahead and declare a 2% regression from six years ago, in a
> test that most certainly has completely different perf characteristics,
> isn't relevant anymore.

Steady on, tiger!
You need to log in before you can comment on or make changes to this bug.