No animation in some animated GIFs

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: blahman75, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12

This url contains an animated gif that used to work prior to firefox 2.0.0.12

After updating to firefox 2.0.0.12 this animated GIF no longer works, it's static.


Reproducible: Always

Steps to Reproduce:
Just visit http://i16.photobucket.com/albums/b36/oysterlicker/emoticons/TFRDE.gif


Actual Results:  
Animation works fine in older firefox and IE but doesn't animate in firefox 2.0.0.12

Expected Results:  
GIF should be animated just like before.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13pre) Gecko/20080208 BonEcho/2.0.0.13pre

Works for me. Could you type about:config in the location bar and see if the pref image.animation_mode is set to normal?
Or else maybe this is caused by an add-on? Try running firefox in it's safe-mode to find out or try a new profile.
(Reporter)

Comment 2

11 years ago
Ok, I've added that pref image.animation_mode (string) and set to 'normal' and it works now.

But I've never messed with those configs before, and it was not there before I added it.

I assume by default the latest mozilla does not have that setting, or those that were updated automatically never had that setting in the first place.

Basically I had to add it in, it was not there before that. Now it works. Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.