Massive reworking of the front end

RESOLVED FIXED

Status

RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: lhansen, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Massive reworking of the entire front end for performance and clarity:

  - switch-based lexer with optimizations for common cases
  - unthreading of the token stream in the parser
  - removal of debugging calls in parser (the compiler could insert this code)
  - lexer/parser interface has limited-length token queue, avoiding consing
  - concretization of token representation to avoid function calls on critical path
  - hash tables instead of linear lists to hash cons (!) tokens
  - allow esc.es to compile multiple files in one go to avoid JIT warmup
  - and more

This patch assumes that #416248 has been applied.  It subsumes #416249.
(Reporter)

Updated

11 years ago
Duplicate of this bug: 416249
(Reporter)

Comment 2

11 years ago
Created attachment 302152 [details] [diff] [review]
Big patch
Attachment #302152 - Flags: review?(tierney)

Updated

11 years ago
Attachment #302152 - Flags: review?(tierney)
Attachment #302152 - Flags: review+
(Reporter)

Comment 3

11 years ago
Changeset 370
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.