this._processor is null error when loading live bookmarks

RESOLVED DUPLICATE of bug 433748

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED DUPLICATE of bug 433748
10 years ago
8 years ago

People

(Reporter: Julian Sikorski, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b4pre) Gecko/2008020623 Fedora/3.0b4pre-0.beta2.16.nightly20080206.fc9 Minefield/3.0b4pre
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b4pre) Gecko/2008020623 Fedora/3.0b4pre-0.beta2.16.nightly20080206.fc9 Minefield/3.0b4pre

I recently updated to the mentioned snapshot, and noticed that there is a regression in live bookmark handling. The following errors are displayed in the error console:
Error: 
Source File: http://feeds.feedburner.com/SkypeGarage
Line: 10, Column: 59
Source Code:
    <generator uri="http://www.sixapart.com/movabletype/">Movable Type 3.33</generator>
Error: this._processor is null
Source File: file:///usr/lib64/xulrunner-1.9pre/components/nsLivemarkService.js
Line: 925

Reproducible: Always

Steps to Reproduce:
1. go to http://share.skype.com/sites/linux/
2. add the feed as a live bookmark
3. try to load it
Actual Results:  
Bookmark does not load and the above error is displayed in the console

Expected Results:  
Bookmark works correctly

I am not sure if this is related, but the few feeds that work, like www.phoronix.com, display dates instead of titles. The regression happened at the same time for me, that is between 20080130 and 20080206. The packages are grabbed from Fedora development repository.
Component: Bookmarks → Places
QA Contact: bookmarks → places
Version: unspecified → Trunk
(Reporter)

Comment 1

10 years ago
Seems to be fixed in 20080209.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 2

10 years ago
Created attachment 309085 [details]
Feed that gives this._processor is null error

This still seems to happen for me, the following feed still shows the symptoms (at the time of writing) in 2008031205:

http://www.warp2search.net/backend.php

I've attached a copy for posterity.

What seems to happen is that a load is started, the first chunk comes back and causes the parser to return a fatal error which causes handleResult() to be called in nsILivemarkService.js. That function nulls out _processor, however the load is still happening so the next chunk of data still arrives, onDataAvailable is called and this._processor is of course now null.

Comment 3

10 years ago
Created attachment 309086 [details]
Feed that gives this._processor is null error

Might help if I upload the actual feed. :)
Attachment #309085 - Attachment is obsolete: true
(In reply to comment #3)
> Created an attachment (id=309086) [details]
> Feed that gives this._processor is null error
> 

It doesn't work, but notice that current XML feed of that site, http://www.warp2search.net/backend.php , works without problem.

Anyway the solution of this bug is not known, so it's not FIXED but WORKSFORME
Resolution: FIXED → WORKSFORME
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 433748
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.