when it installs, it does not work. No pages can be opened.

RESOLVED INVALID

Status

()

Firefox
General
--
critical
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: John Birkimer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.12

Twice now when I have let it update to the new version it kills my ability to browse. No pages will open. I have to do a system restore. I have now had to block new updates. Please let me know when it is safe to renew the automatic update process. Birkimer@Louisville.edu

Reproducible: Always

Steps to Reproduce:
1.Let automatic update occur
2.
3.
Actual Results:  
web browsing ability ends. 

Expected Results:  
Should have simply worked

Continue web browsing ability

Comment 1

11 years ago
10 to 1 that it's a firewall problem (it's even mentioned on your screen !)

See <http://kb.mozillazine.org/Firewalls>.
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> 10 to 1 that it's a firewall problem (it's even mentioned on your screen !)
> 
> See <http://kb.mozillazine.org/Firewalls>.
> 
"Notify me when firewall blocks a new program" is checked, but I received no notification when browser failed.
Your Firewall is broken. 
The firefox.exe changed because of the update. The firewall now just blocks Firefox because the .exe changed and doesn't match the configured whitelisting.
Which Firewall are you using and did you remove Firefox from the firewall configuration and let teh Firewall readd it ?
(Reporter)

Comment 4

11 years ago
Not so. I tried all that, even turned off the firewall. Still can't surf. I had to  do another system restore. Any other ideas?
You didn't answer my questions.
Which Firewall and did you remove the Firefox entry from the Firewall configuration ?
Turning off doesn't help for many (in my eyes broken) firewalls like Kaspersky, Zone Alarm and a few others.

Comment 6

11 years ago
This depends on your Firewall. As per what comment 5 said, I have experienced hands on that turning off Firewalls don't always help. If you uninstall your firewall and still experience this issue please let me know and I will reopen this bug.

Marking this as INVALID.


Thanks,
-Mike
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 7

11 years ago
Go through Add/Remove Programs and make sure that you don't have a firewall. 
The following software are KNOWN to block access even if they're "not loaded"
and don't appear in the system tray or appear as disabled in the system tray. 
Many of them also install windows services that may need to be removed using
the System tool:

Norton Internet Suite/ZoneAlarm (If you have a subscription, you can edit
preferences, if you don't, you will have to uninstall it to stop blocking.)
Kaspersky Internet Security (Again, disabling doesn't help.  Change your
settings as described here
http://support.mozilla.com/kb/Configuring+Kaspersky+Internet+Security and then
restart your computer.  Some users report having to uninstall Kaspersky
entirely in order to get it working.)
CA Internet Suite (You SHOULD be able to configure this one from the system
tray.  If you can't, users have reported that uninstalling works.)

There are at least three other update causes can't connect "bugs" on bugzilla.  Have we agreed on whether they should be INVALID or WORKSFORME or left UNCONFIRMED?

Comment 8

11 years ago
Perhaps we should mark them all invalid, make a wiki entry for conflicting firewalls and what to do, or something and then give them that link.


-Mike
(Reporter)

Comment 9

11 years ago
Running Windows firewall. Firefox was not included as an exemption the last time I had to do a system restore. Firefox again updated while I had removed it from the exemption list, but I still could not connect even after I then included it as an exception. I had to do another system restore and have to manually deny the Firefox update to keep internet connectivity. This sure feels like a bug or defect in the update. Changing the status of this to Wontfix.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → WONTFIX
invalid is correct
Resolution: WONTFIX → INVALID

Comment 11

11 years ago
John Birkimer:

I run Windows Firewall and even with Firefox NOT listed as an exemption, it works for me.  Make sure you don't have any other security software.

In particular, as I mentioned above, we've had many many many reports of Norton and Kaspersky being on users' computers even though they swore up and down that they had already gotten rid of them.  While they could access them from the start menu, the services were still being loaded into memory on startup and hence blocking Firefox.  The bug is INVALID.  A proper uninstall or using Norton's removal tool: http://service1.symantec.com/SUPPORT/tsgeninfo.nsf/docid/2005033108162039 or using Kaspersky's removal tool: http://support.kaspersky.com/faq/?qid=193239279 and then restarting should work.

Comment 12

11 years ago
erm, that should be while they *couldn't* access them from the start menu.
(Reporter)

Comment 13

11 years ago
No firewall program shows in Control Panel Programs and Features nor is there a folder in Programs for one. There was another security suite on this Acer when I bought it but I replaced that with Symantics Antivirus from my university. Windows is the only firewall I have. I guess I can stay with the earlier Firefox or use Opera.
Resolution: INVALID → DUPLICATE
Duplicate of bug: 416423

Comment 15

11 years ago
Bugzilla is really not the best place to ask for technical support, it is a tracking system for actual bugs in various Mozilla products.  If the problem only happens on your computer or with a particular website, you should look into technical support resources. A number of resources are available for Firefox at: http://support.mozilla.com/kb/ .  In particular, you can get help with your question by searching the Knowledge base, or asking on our forums: http://support.mozilla.com/forum or using the newsgroup: mozilla.support.firefox or using the #firefox IRC chat room: irc://irc.mozilla.org/firefox
Resolution: DUPLICATE → INVALID
You need to log in before you can comment on or make changes to this bug.