Closed Bug 416560 Opened 14 years ago Closed 11 years ago

extensions in status bar can cause improper popup display on WinXP

Categories

(Firefox :: Shell Integration, defect)

2.0 Branch
x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 204743

People

(Reporter: dale_schaafsma, Unassigned)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12

 Popup (eg calendar windows like the one on the apple vacations site noted above) will display incorrectly when extensions have a "very wide" display.
 This problem is NOT present on Firefox for Mac OSx, popups display 'correctly' there (although this should probably be tested more thoroughly).

 Workarounds:
- disable extensions
- hide status bar (untested)
- set option as follows:
 tools->options->content->advanced (check "allow javascript to hide status bar")
 Note that my installation defaulted to set this value although Bug298254 implies that this is NOT expected behavior.


Reproducible: Always

Steps to Reproduce:
May occur on other OS's, but WinXP with Firefox2.0.0.12 steps are as follows:
1. tools->options->content->advanced (UNcheck "allow javascript to hide status bar")
2. install several extensions which have "wide" display in the status bar, eg the extension from www.steepandcheap.com or datepicker with a full month/day/year format (%d %b %A %A %B %B)
3. restart firefox to install the extension(s)
4. browse the URL in this bug
5. click on the calendar icon to create the popup

Actual Results:  
6. see the incorrect display...not all of the calendar is visible

Expected Results:  
correct display...i.e. use actual window width for display instead width of status bar for popup windows (or windows which are narrower than the status bar?)
Attached image screenshot of problem
screenshot of problem
Based on comments (mostly comment #5) in 204743, I'd agree...however, I'm not familiar with the code.
 I ran a quick test with a wide status bar (similar to step to in reproduce). That causes the horizontal scroll bar to FAIL to appear when resizing the main browser page to a somewhat narrower width. Also the vertical scrollbar disappears, which it probably should never disappear based on width!
 I suspect that means that display calculations are being done off of the width of the statusbar instead of the width of the actual window. Especially since the disabling display of the statusbar caused the horizontal scrollbar to re-appear.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Version: unspecified → 2.0 Branch
Duplicate of bug: 204743
You need to log in before you can comment on or make changes to this bug.