upgrade from Eudora 8 beta 1 to 8 beta 2 loses / corrupts account info

RESOLVED WORKSFORME

Status

Penelope
General
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: David Taber, Assigned: Matt Dudziak)

Tracking

Details

Attachments

(4 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Eudora 8 beta 2 (penelope a22

Had a perfectly running Eudora 8 beta 1, upgraded to beta 2.  Did NOT uninstall-reinstall --- just upgraded in place and everything seemed to run normally.

When Eudora started up after the upgrade, it started 3 copies of itself.
It also lost track of / corrupted several of my accounts.  The mailbox files themselves appear to be in tact, but all the pointers and account info seem to be corrupted.

Of course, I don't want to downgrade back to beta 1, because who knows what wonders I would find from doing that.


Reproducible: Didn't try

Steps to Reproduce:
1.Install Eudora 8 beta 1 and use for a couple of months
2.Upgrade to Eudora 8 Beta 2 "in place"
3.Discover that most of your mail is inaccessible
((no way I'm going to try to reproduce this one!))
Actual Results:  
Most of the mail accounts corrupted/inaccessible (see attached gifs)

Expected Results:  
Would have expected all mail accounts to have survived the transition.
(Reporter)

Comment 1

10 years ago
Created attachment 302323 [details]
UI symptoms of this bug
(Reporter)

Comment 2

10 years ago
Created attachment 302326 [details]
Install time "crash report" file
(Reporter)

Comment 3

10 years ago
Created attachment 302327 [details]
crash report "UserID" file
(Reporter)

Comment 4

10 years ago
I have saved my prefs.js file (which is doubtless corrupted), but for security reasons I am not posting it here.

Since my email is down, if you are a bug-fix engineer please IM me and I will provide you any info I can via file xfer.

My ID on all IM systems (except ICQ and IRC) is TaberConsulting

My phone is +1 65O 326 2626
(Reporter)

Comment 5

10 years ago
Discovered cannot create new accounts in Beta-2.  Cannot see over 2/3 of my mail.  Uninstalled/reinstalled, no difference.  Dead in the water.

Downgrading to Beta-1...I give up.  Naturally, Beta-1's accounts are all messed up now but it looks like I can recover.  I hope.
(Reporter)

Comment 6

10 years ago
Created attachment 302533 [details]
this is how the folders/accounts should have looked with Beta-2

this is an overview screenshot of how things looked after I reconstructed the accounts in Beta-1.  as I mentioned, I kept the prefs.js file for Beta-2 when things were acting up, and now I have the file for Beta-1 in normal operation. 

contact me, and I will email the files to any developer who wants to troubleshoot this issue.
(Assignee)

Comment 7

10 years ago
I am not able to reproduce the loss of account info, and this is (I believe) the only report of this problem. That said, I DO have a similar problem in my account settings where there is a blank space between two of the accounts. Does not seem to be a serious problem for me, though; just cosmetic.

I'll leave this bug open in case someone else runs into this.

Matt
Severity: critical → normal
(Reporter)

Comment 8

10 years ago
This bug definitely still exists with Beta3.  Same symptoms.  Ignores several of my accounts, creates bogus folders that can't be removed from the UI.

Can't create new accounts either.  Something in prefs.js gets wedged real bad.

"Work around" consists of:
  - remove prefs.js
  - rebuild all your accounts
  - rebuild all of your filters
  - try to find all your passwords
  - waste 2 hours


(Assignee)

Comment 9

10 years ago
I've not been able to reproduce this in any of my test setups, with any of the upgrades (now Eudora 8.0.0b4). I don't doubt that corruption of the settings happens as I have seen it, but I have no reason to believe it is directly related to upgrading from one Eudora to another. Please re-open if you can come up with steps to reproduce and can provide all the files needed to reproduce.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 10

10 years ago
Matt, thanks for investigating.

I only had to migrate one machine to B2, and that pain is long over.  So I suppose this should be closed out, as by definition its irreproducible.
You need to log in before you can comment on or make changes to this bug.