Camino 1.6b2 and above: No right-click-menu in Flash content

VERIFIED INVALID

Status

Camino Graveyard
Plug-ins
VERIFIED INVALID
10 years ago
10 years ago

People

(Reporter: Tobias Stohr, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.12pre) Gecko/20080118 Camino/1.6b2 (like Firefox/2.0.0.12pre)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.12pre) Gecko/20080118 Camino/1.6b2 (like Firefox/2.0.0.12pre)

In Flash content, like films on youtube.com or the About Flash page on adobe.com, you don't get a right-click-menu when right-clicking in the Flash content.
This is reproducable in all current nightly builds, including 1.6b2, except the 1.5 ones. The whole 1.5 branch doesn't have the problem at all.

I downloaded the current Flash Version for Intel Mac 9.0.115 universal and reinstalled it, first deleting all Flash plugins (from ~/Library/Internet Plug-Ins and /Library/Internet Plug-Ins) and after the installation and experiencing the same problem, copied the plugin from ~/Library/Internet Plug-Ins (where installer installs to) to /Library/Internet Plugin-Ins, but not solving the problem.

Firefox 2.0.0.12 doesn't have the problem either, also Safari 3.0.4.

I tested and found the problem in all of these versions:
2.0a1pre (1.9b4pre 2008020900)
1.6b3pre (1.8.1.13pre 2008020900)
1.6b2 (1.8.1.12pre 2008011814)

System:
Mac OS X 10.5.1 on an Intel Mac, German language is used

Reproducible: Always

Steps to Reproduce:
1. e.g. go to youtube.com and open a film
2. do a right- or ctr-click
3. nothing happens but the right-click menu should appear as it does in the html area

Comment 1

10 years ago
I can't reproduce any context menu issues with r115 in trunk builds. If you use Troubleshoot Camino to run under a clean profile, do you still have the same problem?
(Reporter)

Comment 2

10 years ago
Ok, this is getting interesting.
It is definitely not a Camino problem but more like Adobe did some weired stuff.

I used Troubleshoot Camino and tested all Camino Versions reported above and in addition 1.5.5 international and english and 1.5.6pre.
The interesting thing is: all Versions, instead of 1.5.5 int, have this problem. (I don't know how, but accidently I thought the 1.5 branch didn't have this problem in trunk builds. Sorry for that.)
What I figured out is: it depends on the language.

And this is where it starts freaking out:
I changed my systems default language from German to English and tried 1.5.5 int. Now the right-click context menu doesn't appear.
So, I looked into the FlashPlayer.plugin folder and found out, that it has a English.lproj directory in Resources, as well as many other languages, including German. The Localized.rsrc is quite empty, but Flash Player.rsrc has all the English strings.
What I did now: I changed my Systems default language to Italian and French and tested 1.5.5. No menu. The right-click-menu only appears if I have German as my default language.
Interesting: Safari and Firefox have the missing menu problem too, if I don't use German as my default language.

So I went to adobe.com and downloaded Flash Player 9.0.115 again. Now, with English as default language activated. The download site said the language of Flash Player would be English (as it did if I had German as my default language, too). I installed Flash Player. And did the tests again.
Same result: only with German language applied, the context menu shows up.

I tried all of the above things also with Troubleshoot Camino. No difference.


Now: I tried something new.
I changed, my systems default language to English, did a reboot and installed Flash Player again. Now, the context menu shows up in English with all English versions of Camino. Then I changed back to German and got the context menu, too. But also in English.
After a reboot with German language applied, the context menu shows up again and now in German.

I don't know what the problem is, if the plugin is not unloaded after it has been used or how it determines which language to use, but I know that this definitly doesn't work like I expected it to do.

It's for sure not a problem with Camino, so I'll mark this as invalid and write an Email to Adobe about this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.