white bars appear when an images is being drawn

RESOLVED DUPLICATE of bug 416217

Status

()

Core
ImageLib
RESOLVED DUPLICATE of bug 416217
10 years ago
10 years ago

People

(Reporter: Adil Allawi, Unassigned)

Tracking

({regression})

Trunk
PowerPC
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9b4pre) Gecko/2008020904 Minefield/3.0b4pre
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9b4pre) Gecko/2008020904 Minefield/3.0b4pre

While an image is being drawn as it is also downloading white gaps or bars appear.

Reproducible: Always

Steps to Reproduce:
1. Clear the image cache
2. Visit a web page with large jpeg images (e.g. Flickr)
3. Look at the page as it draws
Actual Results:  
White gaps appear as images loads and draws

Expected Results:  
there should be no gaps

this only appears to happen when an image is downloading at the same time as it is being drawn. If the image draws from the cache there is no problem.

This bug started to happen with a nightly build about two days ago. It also coincides with a fix to speed up jpeg image loading that was integrated into the trunk at the same time (Bug 412396) although I dont know if this is related.
(Reporter)

Comment 1

10 years ago
Created attachment 302346 [details]
Screenshot of the issue

This is a screenshot of what I see.
This can't be the product firefox because all the rendering is done by Gecko and that is the Product Core
Component: General → ImageLib
Keywords: regression
Product: Firefox → Core
QA Contact: general → imagelib
Version: unspecified → Trunk

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 416217
You need to log in before you can comment on or make changes to this bug.