linux patch fails with fresh Bugzilla version 3.0.2 install

RESOLVED DUPLICATE of bug 395958

Status

Testopia
General
RESOLVED DUPLICATE of bug 395958
10 years ago
10 years ago

People

(Reporter: Reg Mozilla, Assigned: Greg Hendricks)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/523.10.6 (KHTML, like Gecko) Version/3.0.4 Safari/523.10.6
Build Identifier: testopia-1.3-BETA2

I was unable to run the patch -p0 -i testopia/patch-3.0 on a fresh install of Bugzilla 3.0.2 without getting errors ... the patch thought that one section had been previously applied (I'm sorry my terminal crashed and I can't cut and paste the exact code & error).

Reproducible: Always

Steps to Reproduce:
1. install bugzilla 3.0.2
2. confirm it's working in browser
3. Untar the Testopia 1.3 tarball inside your Bugzilla directory.
4. execute patch -p0 -i testopia/patch-3.0

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 395958
(Reporter)

Comment 2

10 years ago
Thanks Vance.  Nice to know that someone is looking at this stuff.

Bug 395958 involves bugzilla 3.0.1 which isn't supposed to be supported.  3.0.2 is supported.

Also I read somewhere that it might be caused by file permissions/ownership of the testopia files -- although this may in fact related to the next issue that I encountered (once I managed to get the patch to complete) -- although it looks ok, I can't create test plans -- it gives an "The function Bugzilla::Testopia::TestPlan->create requires a name argument, and that argument was not set" error (so maybe the patch wasn't applied properly)  (dojo is working fine)

Comment 3

10 years ago
(In reply to comment #2)
> Thanks Vance.  Nice to know that someone is looking at this stuff.
> 
> Bug 395958 involves bugzilla 3.0.1 which isn't supposed to be supported.  3.0.2
> is supported.

No, not yet. Not by the Testopia team I mean.

Here's the deal -- testopia/patch-3.0 will apply to bugzilla 3.0 *only*. It will not apply cleanly to 3.0.x

See https://bugzilla.mozilla.org/show_bug.cgi?id=395958#c3

Comment 4

10 years ago
All my comments in comment 3 apply to Testopia 1.3. I'm not sure whether it's fixed in Testopia 2.0.
(Reporter)

Comment 5

10 years ago
Thanks Vance ... 

1. Might be worth making it clear that Testopia 1.3 works with Bugzilla 3.0 ONLY ... it isn't clear at all.  Might also be worth putting a link to Bugzilla 3.0 on the Testopia page along with the link to the link to the old version of JSON

2. Is it possible to upgrade Bugzilla to 3.0.2 after installing Testopia?

3. Is anyone working on a 3.0.2 patch for Testopia?

Thanks,

Hugh

Comment 6

10 years ago
(In reply to comment #5)
> Thanks Vance ... 
> 
> 1. Might be worth making it clear that Testopia 1.3 works with Bugzilla 3.0
> ONLY ... it isn't clear at all.  Might also be worth putting a link to Bugzilla
> 3.0 on the Testopia page along with the link to the link to the old version of
> JSON

Please mention this to ghendricks in the #testopia IRC channel.

> 2. Is it possible to upgrade Bugzilla to 3.0.2 after installing Testopia?

That ought to work. It also should have worked if you had answered no instead of yes when patch asked you that question.

> 3. Is anyone working on a 3.0.2 patch for Testopia?

Please ask ghendricks in the IRC channel.
You need to log in before you can comment on or make changes to this bug.