Don't show a context menu for default Bookmarks menu items

RESOLVED DUPLICATE of bug 429469

Status

()

Firefox
Menus
--
enhancement
RESOLVED DUPLICATE of bug 429469
10 years ago
10 years ago

People

(Reporter: Andrés Delfino, Unassigned)

Tracking

({polish, useless-UI})

Trunk
polish, useless-UI
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4pre) Gecko/2008021003 Minefield/3.0b4pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4pre) Gecko/2008021003 Minefield/3.0b4pre

These menu items should not show a context menu:

Bookmarks ▸ Bookmark This Page, 
Bookmarks ▸ Subscribe to This Page...
Bookmarks ▸ Bookmark All Tabs...
Bookmarks ▸ Show All Bookmarks...

Reproducible: Always
(Reporter)

Updated

10 years ago
Version: unspecified → Trunk
(Reporter)

Updated

10 years ago
OS: Linux → All
Hardware: PC → All

Comment 1

10 years ago
Created attachment 306819 [details] [diff] [review]
Like so?
Attachment #306819 - Flags: review?(mano)

Updated

10 years ago
Keywords: polish
Comment on attachment 306819 [details] [diff] [review]
Like so?

No, these are "static" menuitems and thus should be handler by menu.xml.
Attachment #306819 - Flags: review?(mano) → review-
(Reporter)

Comment 3

10 years ago
(In reply to comment #1)
> Created an attachment (id=306819) [details]
> Like so?
> 

Right, that does what I suggest.
(Reporter)

Comment 4

10 years ago
(In reply to comment #2)
> (From update of attachment 306819 [details] [diff] [review])
> No, these are "static" menuitems and thus should be handler by menu.xml.
> 

Could you please indicate which menu.xml? I only found these:

./chrome/toolkit/content/global/bindings/menu.xml
./chrome/browser/content/browser/places/menu.xml

The former, seems like too generic; while de later seems only useful in Library.

in my firefox-3.0b4pre.en-US.linux-i686.tar.bz2.
(Reporter)

Updated

10 years ago
Severity: normal → enhancement
Summary: Default Bookmarks menu items should not shown a context menu → Default Bookmarks menu items should not show a context menu
(Reporter)

Updated

10 years ago
Summary: Default Bookmarks menu items should not show a context menu → Don't show a context menu for default Bookmarks menu items
Also separators have context menu o_o
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: useless-UI

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 429469
You need to log in before you can comment on or make changes to this bug.