0 or 0% leaks results in bloatdiff dying

RESOLVED FIXED

Status

Webtools Graveyard
Tinderbox
RESOLVED FIXED
11 years ago
4 years ago

People

(Reporter: Andrew Schultz, Assigned: Andrew Schultz)

Tracking

({regression})

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

11 years ago
Created attachment 302425 [details] [diff] [review]
patch

Bug 409284 added overly aggressive error checking to bloatdiff, which causes it to bail if there are no leaks (or if the percent leaks is 0 due to roundoff).  Firefox is green only because build-seamonkey-util.pl ignores bloatdiff's failure to run.
Attachment #302425 - Flags: review?(ccooper)
(Assignee)

Updated

11 years ago
Assignee: build → ajschult

Comment 1

11 years ago
Comment on attachment 302425 [details] [diff] [review]
patch

Can you add a comment in the code as to why we don't check leaked or leakPercent? It will make it easier for the next person who has to touch this code. r+ with that.
Attachment #302425 - Flags: review?(ccooper) → review+
(Assignee)

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

7 years ago
Component: Tinderbox Configuration → Tinderbox
Product: mozilla.org → Webtools
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.