no possibility to change delivery mode (to/cc/bcc) for multiple addresses at once

RESOLVED DUPLICATE of bug 440377

Status

Thunderbird
Message Compose Window
--
enhancement
RESOLVED DUPLICATE of bug 440377
10 years ago
8 years ago

People

(Reporter: chrizoo, Unassigned)

Tracking

({ue})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: 1.5.0.10

If the user has a big amount of address lines in the composer window and wants to change for example all the cc to bcc, the user has to manually switch the mode for all addresses ony by one.

Reproducible: Always

Steps to Reproduce:
1. User receives email.
2. User's email address is one of many "to" addresses.
3. User hits the "reply to all" button. 

Actual Results:  
Sender of the incoming mail is put as "to" in the outgoing (draft) mail in the composer window. All recipients of the incoming mail are put as "cc" in the outgoing (draft) mail.

Now, if the user wants to change all cc to bcc, the user has to manually switch the mode for all addresses ony by one.

Expected Results:  
ANY other way to handle the delivery mode switch (to/cc/bcc,etc.) for multiple items.
(As an example ONLY(!): having all the "to","cc" and "bcc" addresses in one single line (respectively!) as opposed to multiple lines, so that the user can switch between the modes for multiple items at once.)
(Reporter)

Updated

10 years ago
Keywords: ue

Comment 1

9 years ago
I prefer multiple selection of single-address lines in the "compose", but chrizoo is right: ANY way which avoids repetitive stress injury and enormous amounts of wasted time is acceptable.

Comment 2

9 years ago
This is a must Thunderbird 3 cannot have. Quite important when managing huge recipient list

Comment 3

9 years ago
Please consider this for Thunderbird 3.  It is a ridiculous UI to have a separate line for each To,CC or Bcc, rather than having a box for each where we can copy and paste addresses between them.

There is an opportunity to do this as the UI is being refreshed (at least for reading messages).

Also, we need people to get a warning and some education if they put more than a a certain number of email addresses in a CC or To (e.g. more than 20?).  They should at least have to confirm that they want everyone to see each others email addresses...
(Reporter)

Comment 4

9 years ago
Rick, Allesandro and Neale: Thanks for stressing the importance of this feature. And Neale's idea for confirming CC/TO>20 is clever. It would need a "don't ask me again" checkbox.
(Reporter)

Comment 5

9 years ago
Allesandro, why do you say TB3 cannot have it ?

Comment 6

9 years ago
(In reply to comment #5)
> Allesandro, why do you say TB3 cannot have it ?

Chrizoo,

sorry it was a mistake "is a must Thunderbird 3 miss" is more appropriate. Do you know I'm seriously considering to move to outlook only for this missing feature? Very often in my day to day work I reply to emails with many people in to and cc and I need to switch their delivery mode (or cancel some of them) depending of the content of the arguments. And doing this line by line, address by address, is very annoying. Outlook solution of drag and drop (single or many addresses at once) is very very useful.

Comment 7

9 years ago
(In reply to comment #6)
> (In reply to comment #5)
> > Allesandro, why do you say TB3 cannot have it ?
> 
> Chrizoo,
> 
> sorry it was a mistake "is a must Thunderbird 3 miss" is more appropriate. Do
> you know I'm seriously considering to move to outlook only for this missing
> feature? Very often in my day to day work I reply to emails with many people in
> to and cc and I need to switch their delivery mode (or cancel some of them)
> depending of the content of the arguments. And doing this line by line, address
> by address, is very annoying. Outlook solution of drag and drop (single or many
> addresses at once) is very very useful.

Sorry: it seems I've serious writing problems! "This is a must Thunderbird 3 cannot miss".
(Reporter)

Comment 8

9 years ago
I completely agree. I have no idea why this line-by-line thinking made it into Thunderbird in the first place. I understand if there are too many things to do at once, after all this is a freeware product supported by dedicated programmers. But in case this is left intentionally as is, I have a hard time understanding the reason for it. Technically speaking it wouldn't be difficult to implement, as TB is already capable of multiple addresses per line, separated with a comma. A copy/paste formatted this way is already accepted.

Comment 9

8 years ago
Same behavior in TB 2.0.0.22 for Mac OS X, and it's a PITA. Why is the status Unconfirmed? Why is nobody working on it?

Comment 10

8 years ago
Feel free to submit a patch to bug 440377.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 440377
You need to log in before you can comment on or make changes to this bug.