Closed Bug 416729 Opened 17 years ago Closed 7 years ago

update notification could use an icon

Categories

(Toolkit :: Application Update, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: dao, Unassigned)

References

Details

Attachments

(2 files)

isn't this a dupe of bug 416340 ?
No, this is a trunk bug.
Attached image screenshot
Keywords: icon
What platforms do we need the icon for?
I think we're capable of showing an icon on all platforms.
Perhaps the firefox icon badged with the icon we created for extension updates?

http://mxr.mozilla.org/seamonkey/source/toolkit/themes/gnomestripe/mozapps/extensions/viewButtons.png

Or just the large version of the icon we created for extension updates might work reasonably well.

Where would we land this icon?
Blocks: 425582
(In reply to comment #6)
> Where would we land this icon?

probably there:
toolkit/themes/winstripe/mozapps/update/
toolkit/themes/pinstripe/mozapps/update/
toolkit/themes/gnomestripe/mozapps/update/

The code part is pretty safe/trivial, and the jar file is easy enough, just needs the icon :)

Dão, I'm not sure if you're the right person to review this?, it's toolkit, but it's basically just theme changes, so I guess I'll just ask and see :)

note the cvs diff viewer gets confused by the +s in the jar files.
Attachment #319928 - Flags: review?(dao)
Comment on attachment 319928 [details] [diff] [review]
Code and jar file changes

Please try to get ui-review for the images first.
Attachment #319928 - Flags: review?(dao)
I used this for testing: http://mxr.mozilla.org/mozilla/source/toolkit/themes/winstripe/mozapps/update/icon32.png
It's been there since 2004, AFAIK it's unused :P
A Firefox icon actually looks pretty good when it's saying 'new Firefox' but AFAIK it's bad form to put a Firefox icon into the toolkit due to branding, and making it depend on browser is no good. I imagine it'll have to be a large form of the update icon.
GNOME's icon theme [Linux] and Tango! share same metaphor.

- usual update: http://svn.gnome.org/svn/gnome-icon-theme/trunk/32x32/status/software-update-available.png
- urgent/security update: http://svn.gnome.org/svn/gnome-icon-theme/trunk/32x32/status/software-update-urgent.png

It could be adapted (appropriately styled) for every environment.
Product: Firefox → Toolkit
I'll be posting new icons for windows once we have them.
Whiteboard: [polish-easy][polish-visual]
uiwanted: attach icons
also, try to find out the various ways software update UI is presented to the user
Actually, if we are using an OS level notification, like a Windows "toast" or OS X growl, the app icon is important because otherwise it isn't as clear who is providing the message.

The larger issue though is that these notifications are displayed based on the premise that the user might actually want to see them, which I personally question (details in bug 489138).  I recommend wontfix and actually disable the notification.
Keywords: icon, polish, uiwanted
Whiteboard: [polish-easy][polish-visual]
This UI was removed from app update.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: