Need to lower character limit on add-on names

RESOLVED FIXED in 5.12.3

Status

defect
P5
trivial
RESOLVED FIXED
11 years ago
3 years ago

People

(Reporter: fligtar, Assigned: gkoberger)

Tracking

Details

(Whiteboard: [blog])

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
Names like "I DON'T KNOW HOW TO DELETE MY OWN THEMES OR I JUST CAN'T ANYWAYS -THEME" and "Gnafi - Synchronize Your Bookmarks! URL BAR Search! Tags & Keywords! Great For Forums!" mess up formatting, but mainly they're just entirely too long.
Justin: Did this by any chance get fixed as part of the new Dev CP?
(Reporter)

Comment 2

11 years ago
No, it didn't. But if we decide on a character limit it should be easy to implement. What does everyone think of 40 characters?
(In reply to comment #2)
> What does everyone think of 40 characters?

As a comparison, that'd be: "I DON'T KNOW HOW TO DELETE MY OWN THEMES" :)
(Reporter)

Comment 4

11 years ago
Posted patch patch, v1Splinter Review
Had to make some changes to the translation box code to better support maxLength in normal text fields instead of text areas.
Assignee: nobody → fligtar
Status: NEW → ASSIGNED
Attachment #343580 - Flags: review?(fwenzel)
It works good so far, and I like how it's counting. However, it won't keep you from *saving* a longer add-on name (i.e., a long name is not considered a form error). Is that intentional?
Attachment #343580 - Flags: review?(fwenzel) → review-
(Reporter)

Updated

10 years ago
Assignee: fligtar → nobody
Status: ASSIGNED → NEW
Severity: normal → trivial
Priority: -- → P5
Target Milestone: --- → Future

Comment 6

9 years ago
Would be nice to get a sane cap to avoid 164 char wonders like this:
"Keep Tube: Download Youtube Videos, Dailymotion, Vimeo, Megavideo, Metacafe, Google, Yahoo, Spike, Myspace, Facebook, Veoh, Break, Current, Redtube videos and more!"
https://addons.mozilla.org/en-US/firefox/addon/75489

Some people are using it like a description.

Comment 7

9 years ago
We should consider fixing this bug in 5.11

Looks bad in zamboni: https://preview.addons.mozilla.org/z/en-US/firefox/addon/75489/
Target Milestone: Future → 5.11
Target Milestone: 5.11 → 4.x (triaged)
Pick a limit, let's do it
Whiteboard: [ddn]
I like 40, like fligtar suggested.

Comment 10

9 years ago
For English 40 is probably fine, but some locales may need more like 70.
(e.g. German text tends to be... long)
At the top of the file: names in de or en-us longer than 40 characters.
At the bottom: the distribution of name lengths in all locales.
Looks to me like a lot of extensions with barely more than 40 chars are still legitimate names (like "The OFFICIAL Washington Capitals NHL Theme").

My highly subjective opinion is, 50 seems to be an *acceptable*, 60 a *generous* limit.
(In reply to comment #12)
> Looks to me like a lot of extensions with barely more than 40 chars are still
> legitimate names (like "The OFFICIAL Washington Capitals NHL Theme").

For some definition of legitimate... a name like this can be easily cropped to something more reasonable.

Comment 14

9 years ago
The problem is that auto-cropping would break some of these legitimate names.

How about this:
1) New char max of 40
2) Auto-crop all over 70
3) Any between 40 and 70 would have to crop manually on edit because the form wouldn't accept the over-the-limit strings, but they aren't forced into an auto-crop right away. These long but not necessarily hideous names would be phased out, rather than chopped off automatically.
(Reporter)

Comment 15

9 years ago
Fred has sold me on 50 with his starry adjectives. I will blog about this so that if we do auto-crop people will have been warned.
Whiteboard: [ddn] → [blog]
I knew those stars would get you.
(Reporter)

Updated

9 years ago
Target Milestone: 4.x (triaged) → 5.12.3
Assignee: nobody → gkoberger
(Assignee)

Comment 17

9 years ago
https://github.com/jbalogh/zamboni/commit/41e5fdcfc950562a9cc42b93204f7e529cfe4bed
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.