Parse ahead speculatively to kick off resource loads early

RESOLVED DUPLICATE of bug 364315

Status

()

defect
RESOLVED DUPLICATE of bug 364315
11 years ago
11 years ago

People

(Reporter: roc, Assigned: roc)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Just an idea I wanted to get down...

If I understand correctly, we have to block the parser to wait for <script> and stylesheet loads to complete before we carry on parsing. This means we have to load those resources essentially one at a time.

One conceptually straightforward way to deal with this would be, when the parser blocks, scan ahead through unparsed content looking for additional resource-loading markup, and prefetch those resources into the cache (in a way that means we don't have to revalidate them if they actually do get loaded once we unblock the parser). The scan doesn't have to be 100% reliable; if it loads a resource we end up not needing, we should be OK in theory and in practice.

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 364315
You need to log in before you can comment on or make changes to this bug.