Windows try server is busted

RESOLVED FIXED

Status

RESOLVED FIXED
11 years ago
6 years ago

People

(Reporter: Waldo, Assigned: bhearsum)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Whatever the problem that hit the OS X box was, it's not what now hits the Windows box.  I tried resubmitting my patch (twice), and it failed on that box (twice).  I then tried submitting a spelling fix that couldn't possibly have caused the error, and it failed with the same error:

http://tinderbox.mozilla.org/showlog.cgi?log=MozillaTry/1202700813.1202703466.10238.gz

Sadly, the Windows box is the one where I need to test the patch, because only Windows defines a GetMessage macro whose #undef-inition my patch removes.
I believe the problem is that my PATH updates put the SDK bin directory after the MSVS8 one and it ends up using the wrong version of MIDL.

I changed this around and am testing a build now.
Created attachment 302605 [details] [diff] [review]
[checked in] put sdk bin directory in front of msvs8 one

This worked fine on the try server.
Assignee: nobody → bhearsum
Status: NEW → ASSIGNED
Attachment #302605 - Flags: review?(rhelmer)
Comment on attachment 302605 [details] [diff] [review]
[checked in] put sdk bin directory in front of msvs8 one

"d:" versus "D:" looks kind of funny, but shouldn't matter.
Attachment #302605 - Flags: review?(rhelmer) → review+
Comment on attachment 302605 [details] [diff] [review]
[checked in] put sdk bin directory in front of msvs8 one

Checking in env.py;
/cvsroot/mozilla/tools/buildbotcustom/env.py,v  <--  env.py
new revision: 1.3; previous revision: 1.2
done
Attachment #302605 - Attachment description: put sdk bin directory in front of msvs8 one → [checked in] put sdk bin directory in front of msvs8 one
(Assignee)

Updated

11 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.